Unable to push into public repository & clone private repos in Bitbucket cloud(Corp Proxy) Edited

Hello Everyone,

I have been using bitucket server user and recently an external vendor had setup a repository on bitbucket cloud. 

I am having issues ever since.

Envrionment 

Using Linux machines with http_proxy,https_proxy variables set.

Issue: 

1) I am able to clone a public repository, but unable to push anything to it.

When pushing I get password prompt and then the error.

Password for 'https://myid@bitbucket.org':  

I entered the password ( I made sure I am entering the correct password)
remote: Unauthorized
fatal: Authentication failed for 'https://myid@bitbucket.org/myid/testpublicrepo.git/'

2) When I try to clone a private repository, I am getting same error

remote: Unauthorized
fatal: Authentication failed for 'https://myid@bitbucket.org/myid/testrepopvt.git/'

Things I have tried:

1)  I tried  curl -L bitbucket.org and responses are coming. 

2) I have entered 104.192.143.2 bitbucket.org in /etc/hosts file.

3) I tried repeating these steps on a repository in bitbucket server and it works like a charm. Here also password is prompted during clone and push operation, but works fine when i enter the password.

git config --global user.name "Username"
git config --global user.email "My Email Id"

git clone http://user@bitucketserver:7990/scm/jen/test.git
cd existing-project
git init
git add --all


git commit -m "Initial Commit"
git remote add origin http://user@bitucketserver:7990/scm/jen/test.git
git push -u origin master

1 answer

This widget could not be displayed.

Any one? Surprising that no one ran into this issue. 

Even my  colleague is trying and he too is facing same issue.

I asked elsewhere, but are you certain that the proxy isn't stripping the Authorization header? That would explain why you can clone, but not push to, public repos, and why you can't interact at all with private repos. Your proxy may also only affect traffic leaving your local network, which would explain why your Bitbucket Server instance is unaffected.

Is SSH an option here?

Sounds logically correct. But I am not sure whether proxy is stripping the header. How can I check that. 

SSH is not working either.

Eric Henry Atlassian Team Sep 25, 2017

Hello,

Were you able to resolve this issue?

Eric Henry
Development Team Lead, Bitbucket Cloud

Hi Eric,

Not yet. I checked with our support team and they too are confused. 

Eric Henry Atlassian Team Oct 02, 2017

Hi Vishnu,

Do you have an Atlassian support ticket to resolve this? I would recommend going that route as it is easier to ensure that we resolve this for you.

Eric Henry
Development Team Lead, Bitbucket Cloud

I've just came across this same issue!

I can clone but get the same error when trying to push.

But in my case I don't have proxy set up.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Friday in Bitbucket

What is your #1 piece of advice to new users getting started using Bitbucket?

Hello Community! My name is Claire Maynard, and I’m a Product Marketing Manager on the Bitbucket team. I’m interested in hearing what advice or tips you have for new users getting started on ...

181 views 11 2
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you