Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,465,232
Community Members
 
Community Events
176
Community Groups

Unable to push changes even though write permissions are given

Edited

Hi,

I was able to push and pull changes initially and after I lost my accesses (some internal issues) and got them again, I am able to pull the latest changes but not able to push. It says I have read-only access but even after I was given the write permissions I am not able to push changes to bitbucket.

 

Could someone help me with this issue?

 

Thanks

 

1 answer

0 votes
Lenin Raj Atlassian Team Jan 11, 2020

Hi @Geetha Ravi

Your user might be missing write permissions for the branch you are pushing to. Eg. master.

This can be checked from Repository settings -> Workflow -> Branch permissions.

Screen Shot 2020-01-11 at 9.18.04 pm.png

I do have the write permissions on the branch and on the whole project but when I try to push the changes it says that I have read-only. we have tried removing the permissions and adding it back but didn't work.

Hey any updates on the issue, were you able to resolve? I am facing a similar issue when giving write access, still not able to update repo

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events