Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,455,380
Community Members
 
Community Events
175
Community Groups

Unable to push anything using SourceTree and VS Code

Edited

Hi,

It's been a few days now and I keep trying to push or pull anything using SourceTree and VS Code.

We have a few projects on hold because of this.

Trying to push while I am logged in using OAuth fails. Trying to push with basic authentication fails. Trying to push with basic auth with app password fails.

 

git -c diff.mnemonicprefix=false -c core.quotepath=false --no-optional-locks push -v --tags origin master:master
remote: Bitbucket Cloud recently stopped supporting account passwords for Git authentication.
remote: See our community post for more details: https://atlassian.community/t5/x/x/ba-p/1948231
remote: App passwords are recommended for most use cases and can be created in your Personal settings:
remote: https://bitbucket.org/account/settings/app-passwords/
fatal: Authentication failed for ''

I tried removing the account, adding it back again, repeat the steps above, nothing.

Reinstall SourceTree, try it all over again, still nothing.

Also, when I try to clone a repo in SourceTree, the clone button is disabled and I get the warning "This is not a valid SourceTree path". 

 

Any ideas? I understand there were some changes made and the recommendation was to create an app password for authentication but that doesn't seem to work for me. It's been a while now and we are considering moving away from SourceTree/BitBucket/Atlassian this week if we cannot fix this.

2 answers

0 votes
Caroline R Atlassian Team Apr 06, 2022

Hi, @bogdangheorghe, thank you for reaching out to Atlassian Community.

If you are using SourceTree for Windows, we have published an article with several steps and things to check to fix authentication issues when updating to App password, so I recommend that you follow these steps:  

If you’re using SourceTree for Mac, you can double-check if KeyChain Access is set as a credential manager for Git, and if so, remove any bitbucket.org credentials from there. 

Please let me know how it goes and feel free to share any additional questions regarding this case. 

Kind regards, 
Caroline 

Take a look at this post THIS post. What fixed it for me was to create an App Password and then set it using this command:

 

git clone https://USERNAME:APP_PASSWORD@bitbucket.org/OWNER/REPO.git

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events