Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Unable to create indexes on Bitbucket during starting.

After updating my docker to the latest version of Bitbucket I can not start it anymore. The log shows me that a failure happened while creating the indexes but without any futher informations:


019-08-16 21:42:45,375 INFO [Caesium-1-1] c.a.b.i.s.i.jobs.StartupChecksJob Running startup jobs for search
2019-08-16 21:42:45,973 ERROR [Caesium-1-1] c.a.b.i.s.i.IndexingSynchronizationService Failed to create indexes: ''[Unknown error, Unknown error, Unknown error, Unknown error]''
2019-08-16 21:42:45,974 ERROR [Caesium-1-1] c.a.b.i.s.i.IndexingSynchronizationService Unable to synchronize the mapping in Elasticsearch

 

Does anybody had already the problem like this and maybe know how to solve it?

Many thanks

Silvan

3 answers

I had exactly the same problem after updating from Docker Bitbucket Server 6.3 to Docker Bitbucket Server 7.2.x. Tried all other options, but the following worked for me.

https://community.atlassian.com/t5/Bitbucket-questions/Bundled-elasticsearch-does-not-work-at-all-for-bitbucket-server/qaq-p/942796

This solution consists of copying the password from <bitbucket docker volume>/shared/search/buckler/buckler.yml to the settings for Elasticsearch in Bitbucket administration (Admin > Server Settings > Search > Elasticsearch password).

Hi Stephen

Thank you very much for you reply. Unfortunately from the first Link the Resolution #1 and #2 did not trigger the reindex. My solution was to delete the docker-container with all files and restore my files afterwards.

Regards

Silvan

0 votes

Hello Silvan and welcome to the Community!

Thanks for including details into the steps prior to your Bitbucket index problems. This type of issue can be a few things, we’ll focus on the most common ones first. You may either have corruption of your index which will need to be recreated. This can be done by following this: Rebuild the bundled Elasticsearch indexes for Bitbucket Server. Alternatively, another issue may be a connection issue with Bitbucket and the Elasticsearch itself. To troubleshoot a connection issue with the index please see Troubleshooting Connection Issues for Elasticsearch.

Please let us know if these assisted with the issue or if it’s still present.

Regards,
Stephen Sifers

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

New improvements to user management in Bitbucket Cloud 👥

Hey Community! We’re willing to wager that quite a few of you not only use Bitbucket, but administer it too. Our team is excited to share that we’ll be releasing improvements throughout this month of...

3,818 views 10 16
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you