Unable to connect to remote Mercurial repository

In SCM Details -> Mercurial Connection Details -> Repository Location I wrote the path of the Mercurial repository I want to manage through FishEye. The repository is on a remote server.

When I click the Test connection I get the fol lowing error: repository not found.

Launching exactly the same hg command from DOS prompt everything works fine and the repository is cloned.

1 answer

1 accepted

0 vote

Hello Marco,

According to our Mercurial documentation before you add your Mercurial repositories, you will need to set your executable location for hg (Mercurial).

Could you please check if this is already configured?

Hi Felipe,

thank you for your answer.

The issue has just been solved. I run FishEye as a service and the problem was the connection account of FishEye service. I changed it from Local System to my network administrator and now everything works fine.

Marco

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Piotr Plewa
Published Dec 27, 2017 in Bitbucket

Recipe: Deploying AWS Lambda functions with Bitbucket Pipelines

Bitbucket Pipelines helps me manage and automate a number of serverless deployments to AWS Lambda and this is how I do it. I'm building Node.js Lambda functions using node-lambda&nbsp...

2,007 views 1 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you