Unable to clone stash git repository over http

I was working with Stash git repositories for a while by now and everything looked normal.

But today I tried to clone git repository and got the following error.

remote: Counting objects: 750, done.
remote: Compressing objects: 100% (571/571), done.
error: RPC failed; result=56, HTTP code = 200| 11.66 MiB/s
fatal: The remote end hung up unexpectedly
fatal: early EOF
fatal: index-pack failed
warning: http unexpectedly said: '0000'

Here is what I see in atlassian-stash.log

SmartExitHandler Request for repo 'XXX' of project 'YYY' from '10.83.51.17' failed: read process '/usr/bin/git http-backend' caused an exception
Process's error output: error: git-upload-pack died of signal 13

I tried multiple times with the same result. Any ideas on what could be the problem ?

I also tried to clone with SourceTree and got the same error.

3 answers

1 accepted

Looks like issue was in my network card settings. After I increased transmit / receive buffer sizes and reset it couple times, git clone started working.

Thank you everybody for help.

Any chance that your repostory is broken somehow? Does this happen with all repos or only a particular one?

I tried 2 other repositories and got the same error.

I have stash installed on Linux VM. Should I run 'git fsck' or other git CLI on this VM ? What directory should I run it in under stash-home ?

It is not very probable that all of your repos are broken. I can imagine 2 possibilities now:

- It is a local issue with the client you are trying to clone to.

- A port (range) of the server is unreachable.

Can you try from another computer? If it works, than it is an issue with the client. If it does not, check your firewall/network settings.

Yes, it looks like local issue at this point. Clone from another computer worked fine although took longer than usual.

If you do not have the latest version of Git installed, I would start by upgrading it.

Upgraded GIT to version 1.9.4 but still see the same issue. Also earlier I did not see it so it is unlikely to be version issue.

This guy solved it by setting the correct permissions on the server (not using stash, but this could also apply to your issue)

http://stackoverflow.com/a/23321710

Yes I saw this post about permissions to directory. That would affect all clients but I have only one client not able to clone. So looks like I have a different issue.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Jun 12, 2018 in Bitbucket

Do you use any Atlassian products for your personal projects?

After spinning my wheels trying to get organized enough to write a book for National Novel Writing Month (NaNoWriMo) I took my affinity for Atlassian products from my work life and decided to tr...

161 views 20 8
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you