Are you in the loop? Keep up with the latest by making sure you're subscribed to Community Announcements. Just click Watch and select Articles.

Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Unable to build pipeline due to missing file and plugin issue


Could someone help me with this error? I'm building an Android project with the default Android pipelines yml on a existing project and I am getting this error. When creating a new project everything seems to work, but this existing project is keep giving me this error. 

3 answers

We got the same error, it was due to a plugin we added.



screenshot (1).png

We weren't really using it, so removing it fixed the issue for us.

Same here, I was not using the lib yes and removing it solved the problem. However in case someone wants to use the plugin I am not sure how it's done.

Like Oluwasegun Ilori likes this

I have this issue and I need to use the library

To fix the issue with secrets-gradle-plugin, simply add a file to your source control with all the keys assigned with safe default values. Configure the created file in your module's gradle file as:

secrets {
    defaultPropertiesFileName = ''

Please refer to the documentation for more.

Hey Norbert,

The file is indeed not there (also not in the project that is working though). Doesn't bitbucket add this directory when cloning it itself (so it makes sense it's not there in my local project)?



Norbert C
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Mar 11, 2022

Hi Bart,

Thank you for your reply.

Basically how Pipeline works is that it clones the content of your repository in the "/opt/atlassian/pipelines/agent/build" directory. 

Can you let me know whether if the "" file is there in your repository's root directory? 

Best Regards,
Atlassian Bitbucket Cloud Support

Hi Norbert,

Yes the file is there (in both the working project and the not working) 

Hi @Norbert C ,

Do you have any idea what else I can try?



Norbert C
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Mar 21, 2022

Hi @scrollbart 

Please excuse me for the late reply. Unfortunately I'm not really familiar with building Android projects with Pipelines. Can you try to debug this issue locally using Docker as it's mentioned in this documentation?

This way we can verify whether if this is a Bitbucket Pipelines or a build issue.

Also would it be possible for you to try @Vijith Menonsuggestion? Does Vijith's workaround works for you?

Please let me know.

Best Regards,
Atlassian Bitbucket Cloud Support 

0 votes
Norbert C
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Mar 10, 2022

Hi @scrollbart 

Thank you for contacting Atlassian Community, my name is Norbert and I'm a Bitbucket Cloud Support Engineer, it's nice to meet with you! Welcome to the Atlassian Community!

Based on the error message, the "/opt/atlassian/pipelines/agent/build/" file can't be found, once you're trying to do the build.

To verify if the file is there or not, can you run the following command and give me the output?

ls -lthra /opt/atlassian/pipelines/agent/build/

I'm looking forward to hear from you.

Best Regards,
Atlassian Bitbucket Cloud Support

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events