Unable to build our Docker image

Alexandre Fillatre February 29, 2024

In our first pipeline step, we're calling `yarn install`, but this fails right away : 

 

+ yarn install
# node[39]: std::unique_ptr<long unsigned int> node::WorkerThreadsTaskRunner::DelayedTaskScheduler::Start() at ../src/node_platform.cc:68
# Assertion failed: (0) == (uv_thread_create(t.get(), start_thread, this))

----- Native stack trace -----

1: 0xca5580 node::Abort() [node]
2: 0xca5600 node::errors::SetPrepareStackTraceCallback(v8::FunctionCallbackInfo<v8::Value> const&) [node]
3: 0xd24949 node::WorkerThreadsTaskRunner::WorkerThreadsTaskRunner(int) [node]
4: 0xd24a6c node::NodePlatform::NodePlatform(int, v8::TracingController*, v8::PageAllocator*) [node]
5: 0xc5e5d3 [node]
6: 0xc5ef64 node::Start(int, char**) [node]
7: 0x7f23b8cd424a [/lib/x86_64-linux-gnu/libc.so.6]
8: 0x7f23b8cd4305 __libc_start_main [/lib/x86_64-linux-gnu/libc.so.6]
9: 0xbb8eee _start [node]



Here's my bitbucket-pipeline :

 

image: google/cloud-sdk:latest

definitions:
services:
docker:
# See https://community.atlassian.com/t5/Bitbucket-questions/Pipeline-broken-after-update-to-v25-0-2-multiarch-prod-stable/qaq-p/2597310#U2598724
image: docker-public.packages.atlassian.com/sox/atlassian/bitbucket-pipelines-docker-daemon:v20.10.24-multiarch-runc-patch-prod-stable
steps:
- step: &build-docker-staging
runs-on:
- self.hosted
- gcp
image: node:20
size: 2x
caches:
- node
name: Build and push docker image
script:
- yarn install
services:
- docker

pipelines:
branches:
master:
- step: *build-docker-staging

 

Using node:20.2 as base image fixes the issue, but we need a newer version.

 

Right now, I have no idea why the build doesn't work, and how to fix that.

 

Thanks

1 answer

0 votes
Syahrul
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
March 3, 2024

G'day, @Alexandre Fillatre 

Could you raise a support ticket with us on our Suppor portal so we can investigate this issue further?

Also, before you raise a support ticket with us, please add --verbose options on your yarn install line in YAML, as they should give us more verbose output that will help the investigation.

Regards,
Syahrul

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PERMISSIONS LEVEL
Site Admin
TAGS
AUG Leaders

Atlassian Community Events