Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,464,918
Community Members
 
Community Events
176
Community Groups

This is my first pipeline- and bitbucket doesn't let me run my pipeline, why is this?

As I mentioned this is my first pipeline- I have enabled two factor authentication- but bitbucket does not let me run my pipeline. It keeps appearing with 

Pipeline is currently disabled for this repository. Repository adminstrators can enable pipelines in repository settings - Pipelines.

when I go there-- I can't switch on the tab on to enable the pipeline-
It shows a little toast message when hovering over the tab and it says enable two factor authentication

I am the admin and I have my two factor on. 

 

1 answer

0 votes
Ben Atlassian Team Jun 27, 2022

G'day Ray!

Welcome to the Bitbucket Cloud Community! :)

I have checked your personal workspace in our administration tool and can see that 2FA is not currently enabled on your Bitbucket Cloud account.

Can you please enable this from Personal Settings (found by clicking your avatar in the top-right) > Security > Two-step verification and try again?
You can also follow this link here:
https://bitbucket.org/account/settings/two-step-verification/manage 

Cheers!

- Ben (Bitbucket Cloud Support)

My collegue has the same issue. But we don't have 2FA enabled and don't want to enable it for now. 

Steps we did:

* created a new test repo in our private workspace
* went to the pipeline-menu and  created with help of the template a maven default pipeline.

On my collegues system, the creating request never comes to an end. If he aborts the action, he finally has a pipeline yml file in his repo. But then system tells, that pipeline need to be enabled first. And if he wants to enable it, system complains about not enabled 2FA ...

I tried exactly the same steps with my account, and this worked. Default maven pipeline get's created and commited within 1sec and finally pipeline runs for the first time.

As far as we saw, we both have the same account setttings regharding security etc.

So I guess this is a kind of bug in BB Cloud?!

Hi @Alexander Christian 

I've just confirmed that we enforce two-step verification on Bitbucket users enabling Pipelines in new workspaces as part of our ongoing efforts to prevent abuse of the service by cryptocurrency miners. This requires users (registered in last 90 days free or paid) to enable two-factor authentication within Bitbucket. This may explain why it works for you and not your colleague and is based on when the workspace was created.

I would recommend asking your colleague to enable 2SV temporarily to enable pipelines. They then should be able to disable 2SV and use pipelines without issue.
If you believe that their account is older than this but are still being forced to make this change, please provide us with the workspaceID.

We have a blog post here that explains more:
https://bitbucket.org/blog/changes-to-bitbucket-pipelines-due-to-crypto-mining-abuse

Cheers!

- Ben (Bitbucket Cloud Support)

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PERMISSIONS LEVEL
Site Admin
TAGS

Atlassian Community Events