Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,295,678
Community Members
 
Community Events
165
Community Groups

The remote authentication server is not available - Bitbucket

Hi,

When trying to sign in as Admin user in bitbucket server, I get the below error:

" The remote authentication server is not available. Please try again later." 

Any help is much appreciated.

Thanks

1 answer

0 votes

This means your server is configured to use a user directory (often external) which is not responding when it asks about the admin who is trying to log in.

In most cases, this will be an external user directory (LDAP or Crowd for example), so you would need to fix that remote server, but there is also an internal directory ("embedded" crowd) running as part of bitbucket.  If that has failed, you'll need to read the bitbucket logs to see why.

I checked the log file and found the below error:

The following URL does not specify a valid Crowd User Management REST service: http://10.1.1.67:8080/rest/usermanagement/1/authentication?username=admin

Looks like the URL is for Jira, but I haven't got any Jira setup done on that server yet.

That suggests that you've told the server to "use Jira for the user directory", but if that Jira is offline, of course, it can't use it.

Hi Nic,

Just noticed this in the log file:

'JIRA User Directory (262145)' is not functional during authentication of 'admin'

Any idea?

Yes, that's saying your Jira is not running, so it can't connect to the user server in it.

I understand that. Any way this issue can be fixed?

I need to login as admin in bitbucket to create new users. Any work arounds or fix?

Hi,

Any help is appreciated. I tried all troubleshooting and still no luck.

Is there a way I can reset the whole bit bucket with out losing any data/code and create the users from the beginning. Its only a few users, but I should be able to create new users.

Thanks

I don't think it's a work-around or fix for anything here, but you've got two options.

Either start running the Jira system that you've configured for Bitbucket to use for the users, or re-configure Bitbucket to use another one.

As you can't log in as an admin, it's likely that you'll need to recover admin access, with which you will be able to set up a new directory and remove the broken Jira one.  See https://confluence.atlassian.com/bitbucketserver/lockout-recovery-process-776640158.html

Thanks for the reply.

Jira was not installed and I installed Jira now. To reconfigure Bitbucket it appears I need the admin login. Is there a way I can re-configure the user directory on bitbucket without admin login?

I tried the lockout recovery process and when I start the bitbucket after the changes by running start-bitbucket.bat as mentioned in the lock out process, the command line gets stuck. Also the Elastisearch service wont start too.

Installing a new Jira is not the answer.  Your Bitbucket was set up to look at a Jira for its users, you need to tell it to use that Jira, and make that Jira available to it, not install things in different places.

I think you should step back, and review all your accounts access.

We have 4 users including admin. 3 users are normal users (developers) who can still login and use bitbucket. Just the admin user cannot login. I tried password recovery but I get below email:

Bitbucket has received a password reset request for 'admin' today at 9:32 AM. 

Bitbucket is unable to reset the password for your account because it is managed by a read-only external directory. Please contact your administrator to change your password.

 If you did not request a new password, you don't need to take any further action and can safely disregard this email. 

- Atlassian Bitbucket Server

If the user access is linked to Jira, how come when Jira was not available all other users could use bit bucket and not admin? Very strange.

Can I reinstall or upgrade the existing bitbucket and will that resolve the problem?

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
TAGS
Community showcase
Published in Bitbucket

Git push size limits are coming to Bitbucket Cloud starting April 4th, 2022

Beginning on April 4th, we will be implementing push limits. This means that your push cannot be completed if it is over 3.5 GB. If you do attempt to complete a push that is over 3.5 GB, it will fail...

2,170 views 2 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you