Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Syntax highlighting for Scala files not working

I logged in to Bitbucket today and noticed that syntax highlighting for Scala files was not working.  I tried a multitude of other files as well and they too were not syntax highlighted.  I tested my file over at pygments and it worked fine.

scala-bitbucket.png

Any ideas how I can get syntax highlighting back?

 

3 answers

As a followup, if I go into "Edit" mode on a scala file, it'll syntax highlight the editable script. It's only when I'm browsing the code in the repository that it is not syntax highlighted.

Yet, if I browse to a Java file, it is syntax highlighted both when I'm viewing it and when I'm editing it.

This is still a problem today, and is painful enough for my team that we are looking into Bitbucket alternatives. Seems like a trivial fix? There are myriad open source syntax highlighters available.

Still happening as of February 28, 2020.

Screen Shot 2020-02-28 at 4.07.00 PM.png

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

New improvements to user management in Bitbucket Cloud 👥

Hey Community! We’re willing to wager that quite a few of you not only use Bitbucket, but administer it too. Our team is excited to share that we’ll be releasing improvements throughout this month of...

3,736 views 10 16
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you