Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,961
Community Members
 
Community Events
176
Community Groups

Switched credentials as instructed now can't access repo?

Per the message about changing credentials if you use bitbucket over https, we followed the steps https://bitbucket.org/blog/deprecating-atlassian-account-password-for-bitbucket-api-and-git-activity - and now we can't access our repos.

To test the credentials we added them under Create app password.  Then from git bash tried git fetch / git pull.  Worked fine, but didn't prompt for new credentials.  Opened Windows Credential Manager, found the bitbucket entry as git:https://[company]@bitbucket.org.  Deleted that.  git fetch now pops open the Atlassian window for credentials, but the new ones created under "create app password" give a fatal error.  

When looking in Windows Credential Manager I see two entries now - git:https://bitbucket.org with the new credentials and git:https://[company]@bitbucket.org with the old.

What step(s) are we missing to get git bash / bitbucket / Jira on the same page with the new credentials?

 

2 answers

0 votes
Norbert C Atlassian Team Jan 25, 2022

Hi @Steve Logan 

Thank you for contacting Atlassian Community, I'm Norbert from Bitbucket Cloud Support, it's nice to meet with you!

I would like to ask if Curtis's suggestion has worked for you?

We're looking forward to hear from you.

Have a great day!

Best Regards,
Norbert
Atlassian Bitbucket Cloud Support

You may have not given that App Password the correct permissions, for it to operate. You may need to create another one, testing the permissions until it works as expected, but doesn't have too many permissions either.

Another option, might be to create and use an SSH key instead. The key can be used to either authenticate as a user, or added to a repository to grant access to that repository.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
TAGS

Atlassian Community Events