Subversion configuration with ViewVC gives me a "Malformed XML" Error

Hello,

I'm trying to configure the Subversion Plugin (atlassian-jira-subversion-plugin-0.10.11.1-distribution) with ViewVC (version 1.1.6).
However, everything I've tried results in a Malformed XML error.

Errors
    svn: E130003: Malformed XML
    Error occurred while updating the repository. Please refer to the log for more details.

The first part of the exception within the log files shows the following:

2013-05-27 13:55:41,164 http-bio-8080-exec-19 ERROR admin 835x116x1 taayw5 129.247.51.66 /secure/UpdateSubversionRepository.jspa [plugin.ext.subversion.SubversionManagerImpl] Connection to Subversion repository https://my-dmz.domain.com/viewvc failed: org.tmatesoft.svn.core.SVNException: svn: E130003: Malformed XML
org.tmatesoft.svn.core.SVNException: svn: E130003: Malformed XML
...

Lets say my domain is: https://my-dmz.domain.com/viewvc/ where I can browse all repository of our domain. If I click on a repository, the domain changes to:

https://my-dmz.domain.com/viewvc/?root=repoSampleName

The repoSampleName contains subfolders, e.g. AndroidApp, while AndroidApp contains the subfolders trunk, branches, tags. If I click on this subfolder up to the trunk, the domain looks like this:

https://my-dmz.domain.com/viewvc/AndroidApp/trunk/?root=repoSampleName

Here is my configuration:

Repository Root: https://my-dmz.domain.com/viewvc
Status:
Inactive (svn: E130003: Malformed XML)
Changeset Format:
https://my-dmz.domain.com/viewvc?root=repoSampleName&view=revision&revision=${rev}
File Added Format: https://my-dmz.domain.com/viewvc${path}?root=repoSampleName&revision=${rev}&view=markup
File Modified Format:
https://my-dmz.domain.com/viewvc${path}?root=repoSampleName&r1=${rev}&r2=${rev-1}&pathrev=${rev}
File Replaced Format: https://my-dmz.domain.com/viewvc${path}?root=repoSampleName&r1=${rev}&r2=${rev-1}&pathrev=${rev}
File Deleted Format:
https://my-dmz.domain.com/viewvc${path}?root=repoSampleName&pathrev=${rev-1}

My View Format is empty, but I tried this one:

View Format: https://my-dmz.domain.com/viewvc${path}?root=repoSampleName&pathrev=${rev}&view=markup

What is wrong in my configuration? I also tried to use the Repository Root: https://my-dmz.domain.com/viewvc?root=repoSampleName

I hope you can help me or point me into the right direction.

Best regards,
Michael

1 answer

1 accepted

You're using the wrong URL

ViewVC is a web interface onto the Subversion (SVN) data, it's not Subversion. That is why it's failing. It's a bit like trying to point Outlook at a web mail page & expecting it to work.

You need to use the URL of your subversion repository.

e.g. http://my-dmz.domain.com/svn/repoSampleName

Forget ViewVC in relation to the interface between Jira & Subversion

Matthew, I'm not sure if I got your idea, but it helped me to fix the Error. I was confused by the provided option of the "Web view" where I can select ViewVC.

My new configuration uses the svn-domain in repository, but the viewvc-domain for the web view. In my case https://my-dmz.domain.com/svn/repoSampleName for svn and https://my-dmz.domain.com/viewvc?root=repoSampleName for the ViewVC web view.

Here is my new configuration:

Repository Root: https://my-dmz.domain.com/svn/AndroidApp/
Status: Active

Changeset Format:
https://my-dmz.domain.com/viewvc?root=AndroidApp&revision=${rev}&pathrev=${rev}&view=rev
File Added Format:
https://my-dmz.domain.com/viewvc${path}?root=AndroidApp&pathrev=${rev}
File Modified Format: https://my-dmz.domain.com/viewvc${path}?root=AndroidApp&pathrev=${rev}&view=diff&r1=${rev}&r2=${rev-1}&diff_format=h
File Replaced Format:
https://my-dmz.domain.com/viewvc${path}/?root=AndroidApp&revision=${rev}&view=markup
File Deleted Format: https://my-dmz.domain.com/viewvc${path}?root=AndroidApp&pathrev=${rev-1}

Is that what you meant?

I still have a problem that I can not see any subversion commits in my JIRA issues. I commited to my repository using the message "JIRA KEY-12 some more information ..", where KEY would be my project key and 12 my current issue number. I think I should see a subversion tab somewhere, but I only see Subversion on the Administration page. Are there any good guides to help me getting started? I started with this guide, but the screenshots look totally different to my JIRA version (5.2.10). In my case, when I open the issue and have a look at "Activity" I only see the tabs All, Comments, Work Log, History, Activity but not the "Subversion Commit" tab.

It can sometimes take a while to index a new repository. It's perhaps worth doing a new commit to check?

You shoudl see a subversion tab on the issue view screen and also one at the project level for any commit associated with that project

I can not see any subversion tab. Here you can see three screenshots:

project administration: http://s7.directupload.net/images/130528/nbj39tai.png

tabs on the left when clicking on the project: http://s1.directupload.net/images/130528/d4hndkfj.png

viewing an issue: http://s14.directupload.net/images/130528/yflktrvg.png

I guess I should see the subversion tab somewhere at these screens.
Is it possible that you provide a screenshot showing the tabs? Any idea why I can not see the tab? I simply installed the plugin and configured the subversion repository. What is the next step? should I see the subversion tab automatically, or do I need to configure something else?

Thanks in advance.

Nevermind, I had to restart the server again (think I did it twice and also removed the old log-files). Now it works. Thank you so much, Matthew! Have nice day :-)

Nevermind, I restarted the server again and it works. Thank you so much!

Nevermind, I had to restart the server again (think I did it twice and also removed the old log-files). Now it works. Thank you so much, Matthew! Have nice day :-)

Glad that it worked, it can be one of these things sometimes, just takes time. Also, be aware that if you go back and edit a commit message, it won't turn up in Jira. Jira only looks at new commits from SVN. Here's the bug report: https://ecosystem.atlassian.net/browse/SVN-59

You can get round it by deleting the index and getting Jira to start again but it can take a few hours to run depending on the size of the repostories.

Suggest an answer

Log in or Join to answer
Community showcase
Piotr Plewa
Published Dec 27, 2017 in Bitbucket

Recipe: Deploying AWS Lambda functions with Bitbucket Pipelines

Bitbucket Pipelines helps me manage and automate a number of serverless deployments to AWS Lambda and this is how I do it. I'm building Node.js Lambda functions using node-lambda&nbsp...

657 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot