Stash slow response time

I am running some tests on stash 2.8.3 with java 1.6 and postgres 8.4. Users are authenticated on a Microsoft AD server. But I think it is too slow, not only for cloning repos but also for navigating on the web interface. I might need to wait more than 2 min to see a response of some pages. And I only have two repos and two groups. Looking at the profiling logs it is common to see tasks taking more than 1000ms to run. Is this normal ? Memory consumption is around 1 GB for this JVM instance but the hardware itself has up to 4 GB. I don't know what might be happening here.

2 answers

1 accepted

Accepted Answer
0 votes
Roger Barnes Atlassian Team Nov 12, 2013

Hi Bernardo, I'd recommend you raise an issue at support.atlassian.com. The behaviour you describe is most unusual and they'll be able to dig into your specific situation more deeply.

Ok, but I only have an evaluating license.

Roger Barnes Atlassian Team Nov 12, 2013

No problem, we'd love to help you get things up and running.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Aug 21, 2018 in Bitbucket

Branch Management with Bitbucket

As a project manager, I have discovered that different developers want to bring their previous branching method with them when they join the team. Some developers are used to performing individual wo...

2,352 views 9 12
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you