Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Stash setup on Linux: Can't access http://ip:7990/ from a remote host

I'm doing a Stash 2.3.0 setup for a client and I noticed that I cannot access it through a remote host.

On the local machine, netstat output:

Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0       *:7990             *:*                     LISTEN         8940/java

Previously, it listened on tcp6, so I added "" to JVM_REQUIRED_ARGS in That solved that, but still no joy.

iptables chains are empty, so I don't see why access could be blocked from the outside. Any suggestions are welcome!

I tried also changing the port. Same result.

The same host is running a JIRA setup. No problem with installation there.

One minor detail, the server is actually EC2

10 answers

Actually, I'm back after restarting my EC2 instance and both http and https connections are working. Sorry I can't provide any help, this one solved itself.

tried it. telnet timed out.

rule out the server, try telnet host:7990, if you get a connect, its your client, probably.

can you ping the server from the remote client? Is there another service you can check with telnet, eg ssh/http? ie validate connectivity of some kind. Whats the infrastructure between server and client, any proxies or firewalls?

I tried changing the port. There's also a JIRA I've installed, currently running. No such problems there.

If telnet failed by timeout it is firewall issues. Cos in other case you should get quick error (if listeneing on wrong interface).

ok, spin another way, can you telnet to the external IP on the server to the port you expect?

it's a firewall. I tried to listen to a port with netcat and see if I could telnet there.

I'm having the same issue. In my case I can telnet to the box fine, but when I load in the browser it refuses the connection. This is true for both http and https configurations. I have both default open on AWS. Any help is greatly appreciated. Stash is DOA for me so far.

Total newbie here, and I'm having the same issue. Can't access from outside; it's behind a VPN, and pinging the inner IP works, as well as ssh and ftp: I'm assuming I just can't http/https from the outside.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Bitbucket

Powering DevOps with Bitbucket Server & Data Center

Hi everyone, The Cloud team recently announced 12 new DevOps features that help developers ship better code, faster   ! While we’re all excited about the new improvements to Bitbucket ...

1,826 views 0 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you