Stash setup can't seem to connect to mysql

I'm running mysql 5.1.73 on Centos 6.2. Trying to run the latest Stash, and it's failing strangely in the first step of the setup.

I have checked and double checked the configuration I'm typing in. I already have a running Jira and Confluence on this same database, all on the same server.

In the configuration step, if I've tried using hostname = "localhost" or "192.168....", and been getting a range of behaviours. Most often, when pressing the "Test" or "Next" button, it simply reloads the page, acts as if nothing has happened, and logs nothing to either the installation or the home directory.
Occasionally I got a red box error saying my configuration wasn't correct, and that time I found an error in the log, showing me that the credentials had been rejected by mysql. HOWEVER, the hostname logged in the error was not the one I typed it! It was a hostname that exists in /etc/hosts/ as an alias for 192.168.... , which leads me to worry that Stash is doing some kind of look-up conversion for no reason?

And, most worryingly, the latest time I tried, in order to get the exact wording of something to copy-paste to this question, it instead gave me a success, and now claims it has gone through the initialization, and I'm on to the next setup step.

I have changed nothing.

I realize this whole thing sounds like a ghost story, but does it ring any bells? How can I trust this going forward?

3 answers

1 accepted

Ok, here's my answer. I believe it was this problem: https://confluence.atlassian.com/display/JIRAKB/User+is+Constantly+Logged+out+of+JIRA
The way I fixed it:
- while setting up stash for the first time, log into Stash from a different browser than you are currently using to log into Jira/Crowd/ etc.
- Set up SSO with Crowd

From then on, I was able to use Stash without problems.

Additional information: I'm now into stash and using it, and was seeing the same kind of constant resetting, this time in the form of logging me out nearly every time I pressed a button. I believe the culprit may be something like this: https://confluence.atlassian.com/display/JIRAKB/User+is+Constantly+Logged+out+of+JIRA

Hi,

Stash has a similar KB that matches the same symptoms that you described. Moving Stash to a different context path if you are running other Atlassian applications would definitely help. Please go through this document to get rid of this issue.

As you are trying to set up Stash to connect to MySQL, please read this document and follow it toroughly.

Please post here eventual error messages/logs so we can help you further.

Best regards,

Thiago Bomfim

Atlassian Support - Stash

Suggest an answer

Log in or Join to answer
Community showcase
Piotr Plewa
Published Dec 27, 2017 in Bitbucket

Recipe: Deploying AWS Lambda functions with Bitbucket Pipelines

Bitbucket Pipelines helps me manage and automate a number of serverless deployments to AWS Lambda and this is how I do it. I'm building Node.js Lambda functions using node-lambda&nbsp...

654 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot