Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,459,443
Community Members
 
Community Events
176
Community Groups

Stash Missing From SourceTree

I am running SourceTree 1.9.10.0 and this past weekend we had the SSL certificate expire for our Stash server. Ever since then I no longer see my saved Stashes in SourceTree and when I try to add something new to Stash I get an error about cygheap base mismatch deleted and an incompatible version of the cygwin DLL.

The error also says to search for cygwin1.dll and to delete all but the most recent version, which should reside is x:\cygwin\bin, where 'x' is the drive I installed on. I searched my entire computer and don't see this DLL, or at least Windows couldn't find it, which is weird because I've not made any changes to SourceTree in over a year, so if it was using that DLL and it's now gone, what would have removed it?

Is there any way to get my Stashes I have saved back without uninstalling/reinstalling SourceTree?

I installed SourceTree on another computer and Stash seems to be working, though I don't see my prior Stashes. How can I get my previous Stashes back?

2 answers

1 accepted

1 vote
Answer accepted

After much Googling, I ended up uninstalling Git, then installing the latest version.

Originally I tried the 64 bit version of Git, but that didn't seem to fix it, so I tried the 32 bit version based on another suggestion. I don't know if it was the 32 bit version that fixed the issue or the fact that I performed a reboot after the 32 bit version and not the 64 bit version.

This also fixed my issue with Terminal in SourceTree throwing an error about needing to rebase a DLL, whatever that means.

Any in case, hopefully this helps someone else.

I have the same error while making a stash or deleting an existing one. I tried various things, but installing 32bit GIT (did not try 64) was the only thing that solved it.

Tip: I had to delete the C:\Users\xxxxx\AppData\Local\Atlassian\SourceTree\git_local for SourceTree to detect the correct one.

Thx Chris for your solution.

On my machine this was Source Tree problem for Mac

1. Add new changes 

2 Make new Stash

3. All stashes will appear immediately

This worked on my Windows machine, as well, although the changes only appeared in Visual Studio's Git Changes window. They still did not appear in Sourcetree. Nevertheless, making a new stash made my older stash appear. Thank you for the tip!

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events