Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,467,691
Community Members
 
Community Events
177
Community Groups

SourceTree's "Remote" button opens dead link on BitBucket server

We are using/testing BitBucket Server and have it working fine with SourceTree on two separate computers. Unfortunately, clicking on the "Remote" button opens up a dead link. Even though I have it set up correctly in Repository Settings:

RepoSettings1.jpgRepoSettings2.jpgRepoSettings3.jpg

When clicking on the Remote button (top right of Sourcetree), I get this:

deadlink.jpg

 

2 answers

1 accepted

0 votes
Answer accepted
minnsey Atlassian Team Nov 23, 2018

Hi

You have an scm in the remote git URL path, is that missing from your root URL?

Version 3.0  makes some changes to this area and you might find it easer.

So, adding scm to the end of the Host Root URL does seem to resolve properly when hitting the "Remote" button:image.png


Thanks!  I must have looked at it for too long trying to figure it out. :-)

Same problem, but adding scm had no effect

Only difference in configuration is that Host Type is "Bitbucket Server"

My problem was that the remote details was set to use generic account, changing to personal account fixed the problem

I am having the same issue, with generic host set, clicking the remote button sends me to https://ba-bit.web.boeing.com/bahd/linter-setup which is a 404 link and if I set it to my bitbucket server account, clicking the button just sends me to https://www.google.com/.  The correct link/ what I wish it would send me to would be https://ba-bit.web.boeing.com/projects/BAHD/repos/linter-setup/browse

I am on Sourcetree version 3.4.6.0 and bitbucket v6.6.3

Any ideas on how to fix this?

Thanks

@Brandon Valley Is your account options having the right settings? Not sure if this could be the problem.

FWIW I am on  Sourcetree version 3.4.5 and bitbucket v7.7.1 but also "Git repository for enterprise teams powered by Atlassian Bitbucket" so the later may affect the behavior. For my personal account host is set to what would be ba-bit.web.boeing.com for you. I use HTTPS protocol which match my account setting. Other people here use SSH but I don't know their account settings.

After a bit of playing around, I think I have found a consistent way of makeing repos cloned with https work, but not ssh, if I set the remote to look like this:

Untitled picture.png

it will give the red exclamation mark on the remote button but it will work, but this does not work if the origin is ssh.

 

Any idea how to make the remote button work with ssh origins?

As mentioned earlier my fix was to change away from Generic Account to Personal Account. But I have one repository that works with the Generic Account, there the difference to you screen dump is:

Host Type = Bitbucket Server
Host Root URL = https://<our domain>
Username = <my initials>

<our domain> correspond to: ba-bit.web.boeing.com

Like Brandon Valley likes this

Somehow our Admin set up pathing with different root paths for HTTP hosting (../scm/) VS SSH hosting (../myproj/).

This results in a SSH clone to be
`../<project>/<repo>.git`
and is correctly mapped in SourceTree; and the HTTP clone to be `../scm/<project>/<repo>.git`.

However, the routing for bitbucket server is unable to resolve the SSH "Remote" path since it ONLY handles HTTP path
`../scm/<project>/<repo>.git`
to view the Repo!

This is complicated by the additional masking of HTTP landing space via domain implementation (bitbucket server).

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events