It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

SourceTree 3.1.3 authentication issues

David Lucchesi Jun 05, 2019

I'm installing SourceTree 3.1.3 on a new computer, while I'm still using it on another computer (version 2.6.10). During the installation, in the "Registration" step, I have to choose between "Bitbucket Server", "Bitbucket" and creating a new account.

 

I chose "Bitbucket" and connect to my atlassian account with Google. But I received a page (Confirm access to your account) with this error message :

"Invalid redirect_uri

This integration is misconfigured. Contact the vendor for assistance."

 

I have tried to disconnect my atlassian account and connect using login/password, but it ended with the same error.

 

Can anyone help me with this issue please ?

Thank you,

David

2 answers

1 vote
James Seddon Jun 05, 2019

Hi @David Lucchesi ,

Welcome to the Community!

It looks like you might be running into this: 

https://jira.atlassian.com/browse/SRCTREEWIN-10965

or

https://jira.atlassian.com/browse/SRCTREEWIN-11942

While there isn't a posted solution for it yet, you might want to go vote, watch and comment on that issue.

Sorry I can't offer more help.

-James

David Lucchesi Jun 05, 2019

Hi @James Seddon ,

 

Thank you for the answer. Indeed I am concerned by the second one (SRCTREEWIN-11942). I will see if it evolves in the following days, I hope so.

Thank you,

David 

Prakash Rai Jun 05, 2019

Hi David, I am having same problem installing sourcetree. Please make a post if you figure out the solution. 

David Lucchesi Jun 05, 2019

Hi Prakash,

 

I have tried this workaround : https://community.atlassian.com/t5/Sourcetree-questions/Cannot-setup-SourceTree-stuck-at-OAuth-authorization/qaq-p/1100327#U1100478 and it worked for me !

Wish you good luck !

Regards,

David

Prakash Rai Jun 05, 2019

Thanks. Now authentication is success, but "next" btn is still inactive to install the application.

success_sourcetree.PNGnotactive_sourcetree.PNG

0 votes
Mikael Sandberg Community Leader Jun 05, 2019

This is a known issue and has to do with OAuth, the Bitbucket team is aware of it and are actively working to resolve it. Check https://bitbucket.status.atlassian.com for more information.

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Published in Bitbucket Pipelines

Building a Bitbucket Pipe as a casual coder

...ipe.sh :  #!/bin/bash source "$(dirname "$0")/common.sh" enable_debug extra_args="" if [[ "${DEBUG}" == "true" ]]; then extra_args="--verbose" fi # mandatory variables R...

3,102 views 1 20
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you