Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Slow SSH clone/pull/push

For a few months now I think, whenever I'm pushing/pulling/cloning (or i guess doing other network related GIT operations) it takes forever before anything actually seems to happen. That is, it takes around 1 minute before it starts fulfilling the task.

I'm using GIT through "Bash on Ubuntu on Windows" and if I clone using HTTPS there's no problem, however, with SSH it takes too long before it starts. I have tested both HTTPS and SSH for Bitbucket and GitHub and it only seems to be SSH for Bitbucket that is slow.

Example: cloning a repo of less than 2MB takes around 1m10s, while only in the last second the files are actually written to the disk.

I don't know if this could have anything to do with the relatively recent update to the Bitbucket IPs, but deleting my "known_hosts" in ~/.ssh didn't not help either. Is this a known issue? Common GIT tasks are becoming quite cumbersome.

5 answers

1 accepted

After breaking my head for a day, have figured out the root cause of the issue.

SSH supports both IPv4 and IPv6 and prefers IPv6 if the DNS retrieves AAAA record, but my ISP doesn't support IPv6, which results in huge delays

We can solve it in two ways

  1. Filter out AAAA replies so that we are left with IPv4 address (too much work)
  2. Set "AddressFamily inet" in /etc/ssh/ssh_config to force IPv4 connection

 

After changing ssh_config do restart ssh client, on Ubuntu the command is

"sudo service ssh restart"

Amazing, that seems to have done it. Thanks a lot for the suggestion.

This was my exact problem, perhaps Movistar Perú doesn't support IPv6 either.

Not surprised.

Thank you!

My problem too. I had been copping 15 minute delays.

Massive thanks.

this was also my problem. 

I even had this happening on an EC2 instance I was remoting into. Thanks a ton!

That was a relief. Thank you!

Awesome! Perfect! This has been going on for a while for me! Thanks so much!

Thank you!!!

It was driving me crazy. Doing "git pull" in any of my repositories was taking 18 minutes... 18 MINUTES!!! to just show "Already up-to-date.".

I just moved to a new home on Feb 29th and I started noticing this in my new home. I was totally sure the problem was with the new internet configuration (a router acting as a switch behind the ISP router) and I tried a lot of configurations but nothing fixed the error. Only today, when I connected my PC with an ethernet cable directly to the ISP router and it didn't fix the error, I started thinking the problem was Bitbucket and not my home network. That made me look for a solution here.

Once I added your setting suggestion to ssh_config, it immediately worked.

Thank you, thank you, thank you.

This worked for me.

* Windows 10

* WSL

* ssh

`git pull` went from minutes to seconds.

This worked for me too!

Thanks. Today you have saved my life. I was struggling since morning.

Thank you a lot!

Thanks. For me:

Set "AddressFamily inet" in /etc/ssh/ssh_config to force IPv4 connection

Navigate to this folder C:\Users\<username>\.ssh

Create new config file if it not presented.

To create a new config file.

Open git bash from the folder and enter below command.

touch config


Once you created the file, open the file and add the below text.

AddressFamily inet

Save it and close the file.

Reload the terminal and try here. It will work

ty mate, this worked for me

this worked for me. thanks

Same problem here (Hungary).

I get ~30KiB/s with git clone via ssh.

Both on IPv4 and IPv6.

Other git providers are about 100x faster on the same network.

same problem here, any suggestion to that?

First time I experience something like that.

Screenshot 2019-11-02 at 15.54.30.png

Can you describe your issue in more details? It seems to me that your issue is more about slow download speed, which seems slightly different.

Did you try the solution giridharkannan posted?

Have you checked if there's a general issue with your download speed (not just in GIT)?

Same problem here

image.png

0 votes
Ana Retamal Atlassian Team Dec 17, 2018

Hi Casper! Are you still experiencing this issue? Did you have a chance to try a different network?

Let us know!

Ana

Hey Ana

Thanks for the suggestion. Apparently there must be something to it. At work I had no problems and turning on VPN from home also helped... question is why :/

Could it be my router or ISP that is somehow filtering that connection? Although I don't see why I would have no trouble with GitHub then...

Hmm, installing Wireshark I can see that it must be something inside bash/git itself, because no packets are captured until after a minute of silence. SSH'ing against GitHub instantly shows packets being transferred however.

Perhaps I should reinstall git or maybe even bash if there's no other way :/

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

New improvements to user management in Bitbucket Cloud 👥

Hey Community! We’re willing to wager that quite a few of you not only use Bitbucket, but administer it too. Our team is excited to share that we’ll be releasing improvements throughout this month of...

3,736 views 10 16
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you