Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Setting up SSH keys for pushing

Hi all, 

This is my first time, so apologies if this is obvious. I have a local codebase I am pushing up to my Bitbucket repository. On the command line, it prompts for my Bitbucket password, and after reading found that I can set up SSH keys and push via SSH to avoid having to enter my password each time. 

I followed this guide: Set up SSH for Git on Windows, but when I got to Step 3 it deviated. In the Settings, I had to enable "Pipelines" in order to access SSH Keys, and then there is no 'Add Key' button in there. It also prompts for both private and public key, while only public in the directions. There is no 'Label' field. I don't know what to do here - I tried filling out the private/public but it did not yield anything. 

I found Access Keys in the Settings, which looked similar to the instructions, but is only for read-only commands. Added the key there anyway, which worked, and then I got what was expected:

"repository access denied. access via a deployment key is read-only."

I am legitimately at my wits end for something I have to imagine is very simple .. Any advice is appreciated. 

2 answers

1 accepted

1 vote
Answer accepted

I realized I am in the Repository settings, when I should be in the BitBucket settings. Well, now I know better. 

Hi @Joe S you might find my notes in another thread helpful.

When using the SSH method on Windows, you have to use the ssh:// protocol for the url. In other words,

git remote set-url origin ssh://<workspace-id>/<repo-name>

Similarly equivalent in the url for the git clone command

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events