Set apache subdomain reverse proxy for bitbucket Edited

I read several documentations "how to make it possible" like these

https://confluence.atlassian.com/kb/proxying-atlassian-server-applications-with-apache-http-server-mod_proxy_http-806032611.html

https://httpd.apache.org/docs/2.4/vhosts/examples.html

I not even try to use https for the moment. First I wanna a small success, access bitbucket via my subdomain...

Running:

Ubuntu 16.04.2 LTS

Bitbucket 5.0.0

Apache/2.4.18

 

/var/atlassian/application-data/bitbucket/shared/bitbucket.properties:

server.port=7990
server.secure=false
server.scheme=http
server.proxy-port=80
server.redirect-port=80
server.proxy-name=mysub.mydomain.mytld

 

/etc/apache2/sites-available/000-default.conf

<VirtualHost *:80>
        ServerName mysub.mydomain.mytld
        DocumentRoot /opt/atlassian/bitbucket/5.0.0/

        ProxyRequests Off
        ProxyVia Off

        <Directory /opt/atlassian/bitbucket/5.0.0/>
        Order allow,deny
        Allow from all
        Require all granted
        </Directory>


          ProxyPass         /bitbucket  http://mydomain.mytld:7990/
          ProxyPassReverse  /bitbucket  http://mydomain.mytld:7990/

</VirtualHost>

 

/etc/apache2/apache2.conf

......
<Directory /opt/atlassian/bitbucket/5.0.0/>
        Options Indexes FollowSymLinks
        AllowOverride All
        Require all granted
</Directory>
......

 

 

restart commands

/etc/init.d/apache2 restart

within /opt/atlassian/bitbucket/5.0.0/bin/
./stop-bitbucket.sh
./start-bitbucket.sh

 

bitbucket base url (bitbucket settings administration)

http://mysub.mydomain.mytld

 

- With the default bitbucket.properties bitbucket works, when I call http://mydomain:mytld:7990/

- With my custom bitbucket.properties, when I call http://mysub.mydomain.mytld/ shows me the index of all files in this directory. When I create an index.html file, it is displayed. But no trace of bitbucket.

 

1 answer

0 vote
Roger Barnes Atlassian Team Thursday

A couple of things to try:

  • Remove the DocumentRoot and Directory sections, these aren't used when proxying and may be getting in the way.
  • Check that mod_proxy is correctly installed and enabled
  • Check the logs after restarting apache

In short, it looks like Bitbucket is working, but apache isn't configured correctly to proxy through to it. Section 2 in the first page you linked to shows the sum total of config you should need, anything extra might be getting in the way.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Thursday in Confluence

Color tables for a shiny Confluence page

...; ## Developed by: Alana Fernando ## Shared with love ## @param style:title=style type|type=enum|required=true|desc=Choose a style.|enumValues=Style1,Style2,Style3,Style4,Style5 ## @param alignment:title...

144 views 8 11
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you