Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,363,857
Community Members
 
Community Events
168
Community Groups

Service account unable to receive email from Atlassian

Edited

I'm trying to get access to a BitBucket repository for a service account, but the account is not receiving the invitation email.  It also doesn't receive email when I create or revoke an API token, but other accounts do.  Our email administrator has determined that the email doesn't make it to our email server, and the issue must be on the Atlassian side.

The nonworking account name is [removed by Atlassian].  I know the account receives external email (tested from my personal yahoo mail account).  A sample working account that does receive email is [removed by Atlassian].

Is there something in the name that is causing Atlassian not to send mail?  I've tried enabling all marketing email subscriptions from Atlassian for the account, with no success.  It receives email from the Community (like when it earns a badge for likes), but nothing from the main site.

 

1 answer

1 accepted

0 votes
Answer accepted
Daniel Eads Atlassian Team Jun 11, 2021

Hi @rbeha , welcome to the Community!

Thanks for providing the second email and screenshot - the first email address in your post actually had a typo in the domain. The other information was helpful in figuring that out! I've edited out the email addresses from your post and removed the screenshot to protect your email addresses.

I've confirmed we were suppressing notifications to that address as we'd previously received errors from your organization's mail server:

550: 550 #5.1.0 Address rejected.

The suppression on our end has been cleared and the next invitation should go through. At that point, if it's not delivered then your email administrator should at least see something in the server logs to troubleshoot. I suspect it should go through fine though, as you noted the account can receive email from your personal yahoo address.

Cheers,
Daniel | Atlassian Support

P.S. as you observed, Community emails use a different mail relay - which is why those emails were delivered but the Bitbucket invitations were not. Just wanted to tie up that mystery :)

It works now!  Thank you so much.

Hi @Daniel Eads ,

We have the same problem with a new user in our company. The email is
<removed by Atlassian>
Can u check please?
I looking forward for your comments. THX

Daniel Eads Atlassian Team Jun 09, 2022

Hi @Luis Alfredo Sandoval Salinas , welcome to the Community!

The user you mentioned was on the suppression list on our end. Based on the error codes, looks like the invitation from Trello and Atlassian Cloud were sent before the email box was set up. I've cleared out the suppression and emails should start going through now. You will need to re-send the invitations though.

Cheers,
Daniel | Atlassian Team

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events