Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Self-hosted pipeline No such image bitbucket-pipelines-dvcs-tools:prod-stable

I've just updated my local self-hosted pipeline, after running into some issues with Docker pull rate limits.
The pull rate limits seem to have been solved, but now the new self-hosted pipeline is throwing this error when I try to build a project:

Status 404: {"message":"No such image:"}


1 answer

1 accepted

0 votes
Answer accepted
Patrik S
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
May 17, 2022

Hello @Charcoa1 ,

Welcome to Atlassian Community!

I went ahead and tried to reproduce this error on my side, but the image was pulled successfully. In this case, would you please try pulling the image directly from the terminal using the following docker command in the same environment where you run the self-hosted runner?

docker pull

Also, could you please make sure you are using the latest runner's image available? You can update the runner's image in your environment by executing the below command :

docker pull

Once you have the images updated please restart the runner container, try running the build again and let us know how it goes.

Hope that helps! Let me know in case you run into any issues.

Thank you, @Charcoa1 .

Kind regards,

Patrik S

Hi Patrik!

I'm guessing for some reason the image wasn't available for about the hour I was trying to get it.
I tried running another pipeline about 8 hours ago and it worked. This was with the same runner container version that didn't work before.

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events