SSL Error Pushing to a Bitbucket Repository

When I attempt to push changes to a specific repository I get the following error:

abort: error: _ssl.c:504: error:14094410:SSL routines:SSL3_READ_BYTES:sslv3 alert handshakefailure

I have tried using TortoiseHg as well as SourceTree (the error above is from SourceTree). I have tried using both ssh and https to access the repository, both fail. I have pushed to this repository before, from this computer with no problems with both ssh and https. Also, I seem to be able to push to other bitbucket repositories I have with the same account.

Has anyone seen this error before?

1 answer

1 accepted

We've disabled SSLv3 across our entire site. Please ensure your client supports TLS, and that TLS is not disabled. We're aware that the hg runtime version 2.7 has a broken TLS implementation, so any versions of Tortoise or SourceTree using that code will also be blocked.

That was the problem. I upgraded to TortoiseHg 3.1.2 (Current Version) with Mercurial-3.1.2 and it fixed the problem. Thank you.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Piotr Plewa
Published Dec 27, 2017 in Bitbucket

Recipe: Deploying AWS Lambda functions with Bitbucket Pipelines

Bitbucket Pipelines helps me manage and automate a number of serverless deployments to AWS Lambda and this is how I do it. I'm building Node.js Lambda functions using node-lambda&nbsp...

1,764 views 1 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you