Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

[SOLVED] log4j is not availble during compilation

Edited

Hello,

I got a pipeline that gives the error:

[ERROR]...KeyValueController.java:[14,24] package org.apache.log4j does not exist

Previous, in the log above, it does look like the log4j jar in fact is downloaded:

Downloaded from central: https://repo.maven.apache.org/maven2/log4j/log4j/1.2.17/log4j-1.2.17.jar (490 kB at 11 MB/s)
...

I can not figure out how the package can not be available then, isn't this strange?

What do you think guys? How do I solve this?

The image I use is:

image: maven:3.6.1-jdk-8

Best regards

Fredrik

1 answer

Problem solved, the mistake I did was that I used this in a parent module:

<dependencyManagement>
<dependencies>
<dependency>
<groupId>log4j</groupId>
<artifactId>log4j</artifactId>
<version>1.2.17</version>
</dependency>
</dependencies>
</dependencyManagement>

 

But I  missed to add this in the module that did not compile:

<dependencies>
<dependency>
<groupId>log4j</groupId>
<artifactId>log4j</artifactId>
</dependency>
</dependencies>

 

Strangely it did compile locally though.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

New improvements to user management in Bitbucket Cloud 👥

Hey Community! We’re willing to wager that quite a few of you not only use Bitbucket, but administer it too. Our team is excited to share that we’ll be releasing improvements throughout this month of...

3,776 views 10 16
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you