Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

SOLVED Pipeline Build Node JS fails with "permission denied, mkdir '/root/.npm'"

Edited

Doing a pipeline build with Node (image: node:10.15.3). First script command is to install a global dependency. That fails when installing one of the sub dependencies and I'm dead in the water. Apparently it cannot access root folder. I'm not a Linux pro, just enough to be dangerous, so I'm scratching my head at this noise. Any thoughts or suggestions?

> sharp@0.22.1 install /usr/local/lib/node_modules/gridsome/node_modules/sharp
> (node install/libvips && node install/dll-copy && prebuild-install) || (node-gyp rebuild && node install/dll-copy)

ERR! sharp EACCES: permission denied, mkdir '/root/.npm'

 

2 answers

1 accepted

0 votes
Answer accepted

Solved. I was a dumbass and was installing the wrong thing.

Hey @Peter Kowalczyk I am having the same issue and I cannot figure out what I am doing wrong, can you elaborate a bit more and what you were installing and what you are installing now?

Like Kostya Kostyushko likes this

Same here, facing the same issue. Any solution for it?
Thanks

The best way I found to install NPM packages globally with Bitbucket Pipelines was to set the user to root:

script:
- npm -g config set user root
- npm install -g packagename

 Source: https://stackoverflow.com/a/54290720/8742362

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

📣 Calling Bitbucket Data Center customers to participate in research

Hi everyone, Are you Bitbucket DC customer? If so, we'd love to talk to you! Our team wants to dive deep to understand your long-term plans regarding Bitbucket DC and Atlassian Cloud. Do you plan...

126 views 2 4
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you