Repository size will not shrink following Git LFS migration and BFG repo cleaner use Edited

One of our repositories is approaching 1 GB in size.  It has a lot of content, so after creating a fork of the repo for testing purposes I attempted to follow the instructions here - https://confluence.atlassian.com/bitbucket/use-git-lfs-with-existing-bitbucket-repositories-829078749.html - to shrink the fork.  It has been more than 48 hours and the size of the forked repo has not changed (although I can see space is being consumed in Git LFS).  Are there other steps beyond this article that need to be followed?

Note: I also followed the process detailed in this SO answer - https://stackoverflow.com/a/37253227 - to no avail.

 

Thanks for your attention.

1 answer

0 votes

Hi Jon! Can you let us know the name of the original repo and the name of the forked repo? I'll assume they are in your Bitbucket Cloud account, if they are in a different one please let us know so we can check the right one. Also, have you tried the steps at Reduce repository size already?

Best regards :)

Ana 

Hi Ana.  The name of the original repo is 'webapp'.  The name of the forked repo is 'webapp-git-lfs-test'.  They are both owned by the 'touchtown' team I am a member of.

I checked the size of the webapp-git-lfs-test repo this morning and it has been doubled since my original message - although I have not taken any action in it since posting my original message.  It went from approx 990 MB to 1.7 GB.  Any idea why???

Yes, I attempted the steps in the link you cited above regarding using BFG repo cleaner to rewrite history and reduce the size against the forked repo (pushes were never disabled to this repo so we didnt need the steps related to that).

Thanks

Hi @Jon Theis @Ana Retamal Ortiz

Did you find a solution to this, The same thing happened to my repo whose size increased from 1.1 GB to 2.6 GB on performing git lfs migrate.

The repository name is JessieiOS.

I've also tried the BFG repo cleaner in the reduce repository size page.

 

Thank You

Hi @Akhil Varma.  Unfortunately, no we did not.  The repo that doubled in the size was the fork of our main repo that we had created for testing purposes.  We received no reply from Atlassian and just ended up deleting that forked repo where the issue occurred.

@Jon Theis Oh, Okay. A git gc from Atlassian worked for us(kinda).

Thanks Anyway.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 06, 2018 in Bitbucket

Upgrade Best Practices

Hello! My name is Mark Askew and I am a Premier Support Engineer for products Bitbucket Server/Data Center, Fisheye & Crucible. Today, I want to bring the discussion that Jennifer, Matt, and ...

451 views 6 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you