Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,457,564
Community Members
 
Community Events
176
Community Groups

Repository size exceeds limit

Edited

Dear Bitbucket,


I got the following error message on the Source page of my directory:

Repository size exceeds limit

This repository is over the 4 GB limit and your contributors are not able to push new commits. To resolve this, reduce the repository size.

Bitbucket mentions that the size of the repo is currently 5.14 GB of 4 GBHowever, when running the git count-objects -Hv command, it shows me the following output:

count: 1
size: 4.00 KiB
in-pack: 65955
packs: 1
size-pack: 101.98 MiB
prune-packable: 0
garbage: 0
size-garbage: 0 bytes


I tried to delete the repository on my local and cloned it again, and the size seems to be about 100 mb. Running the count-objects command on any server shows me a similar result, but I can't figure out why we are exceeding the limit.

Repo: <repo_url_removed>


Thank you in advance,

Jim

1 answer

1 accepted

0 votes
Answer accepted

Hi Jim,

I ran a garbage collection on the repository and its size is 2.7 GB now. The remote repo most likely had some dangling commits and needed a git gc for them to be removed. Did you perhaps rewrite history for this repo?

Could you please take a mirror clone of the repo with the command

git clone --mirror <repo_url>

then run the git count-objects -Hv command in that mirror clone and let me know what output do you get?

A git clone command without the --mirror flag will only pull the repo's main branch locally and not any additional branches the repo may have.

Just a heads up, I removed the repo url from your post to protect your privacy.

Kind regards,
Theodora

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events