Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Repository size exceeds limit

Hi, we got that

This repository is over the 2.0 GB limit and your contributors are not able to push new commits. To resolve this, reduce the repository size.

But git count-objects:

count: 0 
size: 0 bytes
in-pack: 78255
packs: 1
size-pack: 981.66 MiB
prune-packable: 0
garbage: 0
size-garbage: 0 bytes

Repo: https://bitbucket.org/backendpag/pag-ios 

Thanks and regards, Itamar

2 answers

1 accepted

1 vote
Answer accepted

Hi @Itamar Silva ,

I ran a git gc for this repo and its size has been reduced to 990.2 MB.

Please feel free to let me know if things are ok now and if you need anything further.

Kind regards,
Theodora

Hi @Theodora Boudale ,
The repo went back to above 1gb, almost 2gb.
Could you help me again?

Thanks and regards, Itamar

Hi @Itamar Silva ,

I can see that you have opened a support ticket about this issue as well, another git gc was run by the support team before I got to your reply and the repo's size has been reduced even further.

Have you been rewriting history in the repo and removing files from Git history? If so, that would explain the remote repo's current size being smaller than 981.66 MiB.

Kind regards,
Theodora

Like Itamar Silva likes this

Hi @Theodora Boudale 

I rewrote history in the repo and removing files from Git history using BFG. I think my problem was solved.

Thanks for all

Hi @Theodora Boudale 
Our repo is over size limit of 4GB, can you run a git gc on one of our repo?

 

Thanks!

Hi @Jasmine Wang,

Apologies for the late reply, I was on leave last week.

I see that you opened a support ticket and another engineer assisted you with this issue!

In case this occurs again, and to any other users who may come across this post with the same issue:

  • Please create a new question about your issue, instead of replying to this post. This way, in case I'm out of office or on leave, my colleagues will see your question and will be able to assist you sooner (whereas if you leave a reply to someone else's post, my colleagues won't get notified)

  • In case the affected repo is owned by a workspace on Standard or Premium plan, you can alternatively open a support ticket via https://support.atlassian.com/contact/#/. In "What can we help you with?" select "Technical issues and bugs" and then Bitbucket Cloud as product.

Please feel free to let me know if you have any questions!

Kind regards,
Theodora

Hi @Soumyadeep Mandal
I thanks for help, but the repo doesn't have large files. 



Like Soumyadeep Mandal likes this
Like Itamar Silva likes this

@Soumyadeep Mandal 
Thanks for answer, I think the repo needs remote git gc.

Like Soumyadeep Mandal likes this

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

New improvements to user management in Bitbucket Cloud 👥

Hey Community! We’re willing to wager that quite a few of you not only use Bitbucket, but administer it too. Our team is excited to share that we’ll be releasing improvements throughout this month of...

3,741 views 10 16
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you