Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Repository size exceeded 4gb not able to push new commits.

Hi There,

My repository has exceeded the 4gb limit and now I am not able to push new changes.

I actually found the issues, why my repository is that big but to resolve that issue I need to commit with new changes which I am unable to do so.

So, request you if, if you can help me here.



2 answers

1 accepted

0 votes
Answer accepted
Caroline R
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Oct 05, 2022

Hi, @Pankaj Mundra, welcome to the community! 

I found the repo that was over 4 GB, ran a GC against it, and managed to reduce its size. 

I also would like to share with you that we have a feature request to allow users to mark repositories for git GC, as you can check here:

Please consider adding yourself as a watcher to receive the updates as we make progress with this. If you are not familiar with our Feature Request Policy, you can read more about it here.

Feel free to share any additional questions or concerns regarding this case.

Kind regards,

Hi @Caroline R ,


Thank you so much for your help.

Repo size is reduced and I have removed the unwanted files and folders from it.


Just wanted to know if you can tell me what is the current repo size?



Pankaj Mundra

Hi @Caroline R ,


As per our last conversation, I have already removed the unwanted files but still after 2 months repo size is automatically increased.


Request you please reduce the size of repo from your end.

I ran "git gc"

Than I ran "git count-objects -vH"

Below is the output:

count: 0
size: 0 bytes
in-pack: 40155
packs: 1
size-pack: 1.45 GiB
prune-packable: 0
garbage: 0
size-garbage: 0 bytes



Pankaj Mundra

1 vote
Fabio Racobaldo _Herzum_
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
Oct 05, 2022

Hi @Pankaj Mundra ,

welcome to the Atlassian community!

You can take a look to the following thread

Btw, my suggestion is to contact Atlassian support to perform a check.


Hi @Fabio Racobaldo _Herzum_ ,


Thanks for your reply, I already gone through many previously asked questions and found that from Support.



Pankaj Mundra

Suggest an answer

Log in or Sign up to answer
Site Admin
AUG Leaders

Atlassian Community Events