Removing a branch from sourcetree.

I tried creating branch through source tree by hitting the branch button on the ui. I forgot that I had to create a remote repo too so I did that and hit checkout from the website. I followed the popup that came up in source tree and now I have two of the same branches: one that exists local and remote and another that is just local. I tried to delete the local one but I get the error " Cannot delete the branch 'branch-name' which you are currently on."

 

https://www.dropbox.com/s/p1s0njp4ifue2h7/Screenshot%202015-05-17%2013.16.12.png?dl=0

1 answer

This widget could not be displayed.

Oops, had to checkout to a different branch first. Fixed it.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Aug 10, 2018 in Bitbucket

What is your #1 piece of advice to new users getting started using Bitbucket?

Hello Community! My name is Claire Maynard, and I’m a Product Marketing Manager on the Bitbucket team. I’m interested in hearing what advice or tips you have for new users getting started on ...

245 views 14 2
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you