Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Remote branch checkout failing : failed to execute prompt script (exit code 1)

Some of members in my developer team are having issues checking and and switching to new branches. We are using Sourcetree with our repositories stored on Bitbucket. They are able clone the repository fine but when they attempt to checkout a remote branch, the checkout process gets stuck and displays these logs.

bash: /dev/tty: No such device or address
error: failed to execute prompt script (exit code 1)
stty: 'standard input': Inappropriate ioctl for device

If you cancel the process, you'll see the all changes from the branch appear in workspace as unstaged files. If you try and do any other operations, your told another git process is running since the lock file wasn't removed as the checkout process was never able to complete.

The issue affects the members for multiple git repositories making me assume it could be an account based issue.

Any ideas what could be going on?

1 answer

1 accepted

2 votes
Answer accepted

Hello @nick.maunder ,

This seems to be an issue with bash support in Windows (I found a bunch of similar reports for other software running on Windows). Can you confirm that people that are facing this issue in your team work on Windows machines?

I'm not an expert in Windows config around this, unfortunately, but can you check which git does Sourcetree use (see this documentation page)? Can you please try switching over to another option and check if the problem persists?

Cheers,
Daniil

I can confirm that we are running on Windows. I'll look into your suggestion and will get back to you.

Nick

What we found that worked was changing over from embedded git to system git.

Thanks for your help Daniil.

Like # people like this

Cool, thanks for confirming this!

I'll let the Sourcetree team know about this issue with the embedded git.

Cheers,
Daniil

Daniil Penkin, has the Sourcetree team made any progress on fixing this?  Two people on my team have also been dealing with this problem since April 2020.

@Daniil Penkin we are having the same issue as well.

Thanks, it's worked for me too. Changing embedded to system.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

📣 Calling Bitbucket Data Center customers to participate in research

Hi everyone, Are you Bitbucket DC customer? If so, we'd love to talk to you! Our team wants to dive deep to understand your long-term plans regarding Bitbucket DC and Atlassian Cloud. Do you plan...

184 views 2 4
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you