Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Pushing file to clients repo returns 400 after exceeding some file size, is there a size limitation?

Mikhail Kotelya
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
June 20, 2023

I'm using OAuth consumer to upload files to clients repo described here - 

https://developer.atlassian.com/cloud/bitbucket/rest/api-group-source/#api-repositories-workspace-repo-slug-src-post

Whenever I'm uploading files up to 1 mb everything running smoothly, when file size exceeds 1,5 mb I'm getting 400 error code without explanation, I suggest problem has to do with size limitation of this api or something on the user's side (his repo size limitations), tried it for multiple users, same result

 

Here's my code - 

Screenshot 2023-06-20 at 17.56.04.pngScreenshot 2023-06-20 at 17.56.22.png

1 answer

0 votes
Theodora Boudale
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
June 21, 2023

Hi Mikhail,

The 400 error indicates a bad request, for example, it might be a missing attribute/parameter.

The limit for uploading a file via API is 500 MB (https://jira.atlassian.com/browse/BCLOUD-18999), which is well above the size of the files you are uploading.

Are you able to upload one of these files using a curl command as follows?

curl -X POST -u username:app-password https://api.bitbucket.org/2.0/repositories/<workspace-id>/<repo-slug>/src -F /repo/path/to/myFile.json=@myFile.json -F branch=test-branch -F message="my commit message"

I formatted with bold the values you need to replace.

Kind regards,
Theodora

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
TAGS
AUG Leaders

Atlassian Community Events