Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,467,212
Community Members
 
Community Events
177
Community Groups

Pushing docker images to self hosted r

Hi, I have spun up a docker registry on docker.domain.com.

 

From any machine I can login to the registry via:

docker login -u username -p password docker.domain.com

 And from the browser if I browse to https://docker.domain.com/v2 I get the typical Basic Auth pop up to enter credentials. After logging in I get the typicial blank {} response.

Now, I have a pipeline (the docker template from bitbucket) that contains (I know this is not safe, I was just trying to get to the error):

- docker login -u username -p password docker.domain.com

Which is the same line as before. But this time when I run the pipeline I get:

Error response from daemon: Get https://docker.domain.com/v2/: net/http: request canceled while waiting for connection (Client.Timeout exceeded while awaiting headers)  

2 answers

0 votes
Caroline R Atlassian Team Jan 24, 2022

Hi, @Martí Bastida Comas, thank you for reaching out to Atlassian Community.

As you confirmed it works locally and by the error message you received, what could be happening is that your private docker registry could be behind a firewall and not allowing the pipeline to connect. If that’s the case, you would need to ensure that these IPs are whitelisted:

Please let me know how it goes and feel free to share any additional questions or concerns regarding this case. 

Kind regards,
Caroline 

Thanks @Caroline R

I will give it a try and come back.

 

But I doubt it's the problem. The registry is hosted in a VPS and I have not configured a firewall. But I will check with the VPS provider just in case.

0 votes
Pramodh M Community Leader Jan 21, 2022

Hi @Martí Bastida Comas 

If you are using custom docker registry, try with v1 as described here

https://docs.docker.com/engine/reference/commandline/login/

If you have solved the issue, feel free to post it here

Thanks,

Pramodh

Hi @Pramodh M and thanks for the reply.

 

From what I have read on the post you are suggesting that I need to install a credential store helper on the pipeline? 

 

Because the documentation mentions a /v1 path. But it is part of the example on how to configure a credential store.

Excuse me @Pramodh M for my insisting but I don't really understand how the link you sent me can help with the problem I'm struggling.

 

The links seems to work around the idea of using an external Credential Store to increase security. How can this help me?

Moreover, from any machine other than the bitbucket pipelines the docker login command works...

 

Thanks

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events