Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Push fails with errors Edited

Hello,

I've setup Bitbucked on my NAS (QNAP) and the system seems to run good so far.

However, when I create a new repository and want to push something (with the default terminal commands that are shown), in this example a 1KB php test file, it it fails with errors.

I've tried to push using SSH and HTTP (HTTPS) but both fail. 

 

Push with SSH gives me the error:

remote: env: can't execute 'perl': Not a directory

 

Push with HTTP / HTTPS gives me the error:

error: RPC failed; HTTP 500 curl 22 The requested URL returned error: 500 

fatal: The remote end hung up unexpectedly

fatal: The remote end hung up unexpectedly

Everything up-to-date

 

 

Any idea would be highly appreciated as I can't work currently.

For official Atlassian support staff I can also share user credentials for the Bitbucked or SSH credentials. Let me know how to send you these via PM or email.

I've used a Stash system recently on the same NAS but the interface became unusable after an OS update. (Lots of CSS an JS errors which lead to unclickable elements in the interface which is why I setup a complete new Bitbucked instance.)

2 answers

1 accepted

0 votes
Answer accepted

Hi Felix

Just as a follow-up to the ticket we've resolved together, steps we've applied to make your NAS run Bitbucket Server, for the reference of others trying to run Bitbucket on QNap.

1. We've installed QGit for (Git package for QNAP)

2. We've removed dead git links from /usr/bin

3. Created links in /usr/bin  pointing to new gitgit-upload-pack and git-receive-pack

After these steps we were able to successfully run Bitbucket and import all the repos from Stash to Bitbucket.

Best regards,
Tomasz Tokarczuk
Atlassian Support

Thanks for the sum up and your support again!

Felix

Hi, 
I have the server up and running, I can clone projects bit on push I'm getting the same error. Can someone help me to understand where do I point the new links?
I have:

git -> /share/CACHEDEV1_DATA/.qpkg/QGit/bin/git*
git-cvsserver -> /share/CACHEDEV1_DATA/.qpkg/QGit/bin/git-cvsserver*
git-receive-pack -> /share/CACHEDEV1_DATA/.qpkg/QGit/bin/git-receive-pack*
git-shell -> /share/CACHEDEV1_DATA/.qpkg/QGit/bin/git-shell*
git-upload-archive -> /share/CACHEDEV1_DATA/.qpkg/QGit/bin/git-upload-archive*
git-upload-pack -> /share/CACHEDEV1_DATA/.qpkg/QGit/bin/git-upload-pack*

I thought it was to change to:
git -> /share/CACHEDEV1_DATA/.qpkg/BitBucket/bin/git*
But I don´t have anything inside the bin.


These are the other folders under /share/CACHEDEV1_DATA/.qpkg/BitBucket

 bitbucket/
 jre/
 BitBucket.sh*
 bin/
 data/

 

In these folders, I don't have "git" or "git-upload-pack", etc...

On my server the local storage is:

Shared directory

/share/CACHEDEV1_DATA/.qpkg/BitBucket/data/shared

/share/CACHEDEV1_DATA (/dev/mapper/cachedev1)



Thanks in advance

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

Powering DevOps with Bitbucket Server & Data Center

Hi everyone, The Cloud team recently announced 12 new DevOps features that help developers ship better code, faster   ! While we’re all excited about the new improvements to Bitbucket ...

1,926 views 0 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you