Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Pull Requests showing empty diffs

Lately Pull-Request-View is showing files as "empty diff" on the left while correctly reporting the number of added / removed lines in the files tree.

Same problem in "old" Pull Request view.

 

Is this a known Bitbucket Bug? Is there a workaround to get the correct diff?

bug.png

8 answers

I am also facing the same issue.

 

Ctrl + shft + r didn't solve the issue for me.

Ditto - this is happening repeatedly. We can sometimes decline the PR and try again but now we're seeing it over and over on the same changes.

For anyone who has this problem in the future and ends up here, one possible cause (and what happened in my case), is that the PR has whitespace-only diff in the file, and my "PR Viewing Preferences" were set to not show whitespace changes. Changing it to show whitespace changes fixed the problem

As of today, we also have this problem. Hard reloading or another browser (Firefox, Safari, Chrome) doesn't fix it. Very frustrating.

How did you eventually fix this then

Deleting the bad PR and re-creating it works for me when this happens.

Like pradipta likes this

The other half of this problem is that bitbucket won't allow me to merge the PR. The commits are there, and shows the diff on the commit, but the PR interface is broken.

I am also getting this same error "Empty Diff".  


Any ideas to root cause / fix?

Screen Shot 2020-06-07 at 1.51.48 PM.png

It was failing me with Chrome, too. But with Firefox I was going fine.

I also checked that when I went to see a commit from the PR, the display worked correctly again when I came back.

Suddenly facing this right now. Don't even know why it happens. My colleagues could view the PR correctly but I can not

I too faced the same issue , hard reloading(cmd+shift+R) the page worked for me.

Like # people like this

Wow. Thanks @Bhanu Prakash Vejju 
Worked for me. Ctrl + shift + R on Linux

We faced the same issue.
Is there any decision?

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

New improvements to user management in Bitbucket Cloud 👥

Hey Community! We’re willing to wager that quite a few of you not only use Bitbucket, but administer it too. Our team is excited to share that we’ll be releasing improvements throughout this month of...

3,845 views 10 16
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you