Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Pull Request from Terminal/Bash, getting XSRF Token Not Found Error

hello

in my continuing quest to automate a Pull Request from a shell script, I am trying to do a PR, but getting the following error:

 

XSRF Security Token Missing

 

I have tried using:

-H "Content-Type: application/json" -H "X-Atlassian-Token:no-check"

But this hasn't solved the issue. I can't see any other avenues to try in the documentation. Anyone have any ideas? Is this even possible?

 

thanks a lot!

1 answer

here is the full Curl request if that helps

 

curl -X POST https://MYHOST.cloud/projects/AP/repos/$REPO/pull-requests \
-u $USERNAME:$PASSWORD -H "Content-Type: application/json" -H "X-Atlassian-Token:no-check" --request POST \
--data '{
"title": "$COMMIT_TEXT",
"description": "automated PR. $COMMIT_TEXT",
"state": "OPEN",
"open": true,
"closed": false,
"fromRef": {
"id": "$NEW_BRANCH"
"repository" {
"slug": "$REPO",
"name": null,
"project": {
"key": "AP"
}
}
},
"toRef": {
"id": "develop",
"repository": {
"slug": "$REPO",
"name": null,
"project": {
"key": "AP"
}
}
},
"locked":false
}'

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

New improvements to user management in Bitbucket Cloud 👥

Hey Community! We’re willing to wager that quite a few of you not only use Bitbucket, but administer it too. Our team is excited to share that we’ll be releasing improvements throughout this month of...

3,927 views 10 16
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you