Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Property 'MsDeployServiceUrl' must be non-empty

I get this error error from bitbucket pipeline windows runner. how can I troubleshoot this error?

1 answer

1 vote
Theodora Boudale
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Nov 13, 2023 • edited Nov 15, 2023

Hi @Febin Thomas and welcome to the community!

The error indicates that the property 'MsDeployServiceUrl' doesn't have a value.

Do you see this error in the output of a command that is running during your Windows Runner build?

Are you using MSBuild and is this the property in question?

If so, have you configured this property in your code?

Kind regards,

Hi @Theodora Boudale , Thanks for replying.

But is the given link a valid one? I get 404 code.

I have added the value as an unsecured repository variable. 



and the variable name is used in my bitbucket-pipeline.yml file  as follows

dotnet publish

I get the same error.
Please note my repository access level is admin
MicrosoftTeams-image (3).png
Theodora Boudale
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Nov 15, 2023

Hi @Febin Thomas,

The link was missing a parenthesis, sorry for that, I fixed it and the link should work now.

I would suggest trying two things to narrow down if the issue seems to be specific to the runner or not:

1. Try replacing $my_server_name with the actual value in the bitbucket-pipeline.yml file for testing purposes to see if the issue is also reproducible.

2. Try running this build outside of the runner in PowerShell, on the same computer where you have the runner. Clone the branch of the repo where the build runs and do a git reset to the commit of the build. Then, execute the commands of your bitbucket-pipeline.yml file. You would need to provide values for any Pipelines variables you are using.

If the issue is reproducible in both cases, then it is most likely related to your project's configuration and you could try reaching out to Microsoft's Q&A for guidance.

If the issue is not reproducible without the runner, you can create a ticket with the support team, provide the URL of the failed build and the output that you get when you run the build in PowerShell outside the runner, and ask for assistance.

You can create a ticket via, in "What can we help you with?" select "Technical issues and bugs" and then Bitbucket Cloud as product. When you are asked to provide the workspace URL, please make sure you enter the URL of the workspace that is on a paid billing plan to proceed with ticket creation.

Please feel free to let me know if you have any questions!

Kind regards,

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events