Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,368,886
Community Members
 
Community Events
168
Community Groups

Problems connecting Azure DevOps to BitBucket Cloud

Anyone have any success setting up Azure DevOps pipeline to connect to BitBucket Cloud? 

We can get it connected to see list of repos using grant access or basic auth with app password but once you select a particular repo it fails with:

Unable to get the path contents from the Bitbucket repository 'workspace/reponame' for the branch or source version 'master' and path ''. It is possible the specified path is a file. Error from Bitbucket: Forbidden

Permissions are set correctly. 

Also tried to use oauth consumer but was unable to find the proper callback url for azure devops anywhere on the net. 

I know  this may be Azure DevOps issue but since it's to use BitBucket Cloud I wanted to post here in case someone else has hit this same issue before. 

 

1 answer

Yes, we have these working, with both OAuth2 (grant) and Basic (app password).

I have tried to reproduce your error.

  • I have given inadequate permissions to the app password used in the Service Connection: this prevents creating the connection.
  • I have created a repo with only a nonstandard branch (default branch != 'main' or 'master): works fine.
  • I have removed the app password after creating the service connection: valid error, different to the one you report.

It seems ADO is handling everything correctly. We can go through how you create your Service Connection in more detail, if you like? And check how you've set up your repository and pipeline. Can you post the steps you go through for creating a Service Connection to a BitBucket Cloud repository?

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PERMISSIONS LEVEL
Site Admin
TAGS

Atlassian Community Events