Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Problems accessing my Bitbucket repositories on a terminal or Sourcetree but not online

I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
Oct 17, 2023


I can log into my Bitbucket account on using my email address and the corresponding password without any problem. However, when I try to "git pull" a repository using a terminal it asks me for the password associated with my username (not email) and it does not work ("Invalid credentials" message) when I enter the password which does work for my email in I note that the mentioned username is the one which I can see associated to my Bitbucket account when I log in using my email. I have similar problems in my Sourcetree app: when I "pull” a repository, it returns "Invalid credentials”. And when I try to add a new account in Sourcetree, it only allows me to include a username for the new account but not an email address. I tried to change the Bitbucket password by going to “Can't log in?” on but they sent a recovery link with the option to include a new password only for the account associated to my email address (not to my username). I then deleted the repository on my laptop and tried to create it again using "git clone” on a terminal but it returns an error saying that "The authenticity of host ' […] can't be established”, “This key is not known by any other names. The requested repository either does not exist or you do not have access. If you believe this repository exists and you have access, make sure you're authenticated.fatal: Could not read from remote repository.Please make sure you have the correct access rights and the repository exists.”. I note that this repository which I try to clone on a terminal in my laptop I can access no problem when I log into using my email address.

I note that it was all working fine in my previous laptop and these problems occur only in my new laptop.


I would very much appreciate any help on this problem: is it the same Bitbucket account associated both to my username and to my email address? If so, why does the password associated to my email address not seem to work for my username? And, if not, why is this username the one that appears in my Bitbucket online account under my email address and how can I change the password for the account associated to my username (not to my email address)? Or is my problem of a different nature than passwords/accounts, e.g., maybe related to something like ssh keys, etc?

Many thanks in advance for any help!

1 answer

0 votes
Theodora Boudale
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Oct 18, 2023

Hi @marccasals and welcome to the community!

We have deprecated the use of account passwords for Git over HTTPS and API:

Your account's password can be used only for logging in to from browser. If you want to clone, pull, or push to a repo with HTTPS, you can generate an app password for your account and use that instead of a password (in combination with your username):

SSH doesn't require password authentication, authentication is done with the SSH keys you set up for Bitbucket Cloud. If you prefer to use SSH instead of HTTPS, please ensure you set up SSH keys for Bitbucket Cloud on this laptop:

If you have any questions, please feel free to reach out!

Kind regards,

Suggest an answer

Log in or Sign up to answer
Site Admin
AUG Leaders

Atlassian Community Events