Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,293,676
Community Members
 
Community Events
165
Community Groups

Problem configuring pipelines composer install errors

We're having trouble getting pipelines to work.

We probably just need some help configuring it.

So far we are getting errors on `composer install`

[See attached image]Screen Shot 2018-05-17 at 12.23.06.png

Does anyone have any advice?

Thank you

3 answers

1 accepted

3 votes
Answer accepted

We managed to get a bit further after we found this documentation, which luckily mentions installing php gd on Pipelines part way down. Documentation advises about `docker-php-ext-configure` and `docker-php-ext-install`: https://confluence.atlassian.com/bitbucket/php-with-bitbucket-pipelines-873907835.html

We then managed to also install the php zip extension using `docker-php-ext-install zip`.

Success.

We're now getting errors for other reasons (trying to run Laravel Dusk) but the core issue we created this thread for seems to be resolved.

thanks for pointing to right direction. documentation is bit outdated now, for php8 these settings worked for me

- apt-get update && apt-get install -y libfreetype6-dev libjpeg62-turbo-dev libpng-dev
- docker-php-ext-configure gd --with-freetype --with-jpeg
- docker-php-ext-install -j$(nproc) gd
Farooq AK I'm New Here Jan 02, 2022

Thank you for pointing me in right direction 

- curl -sS https://getcomposer.org/installer | php -- --install-dir=/usr/local/bin --filename=composer
- composer require phpunit/phpunit
- composer install

docker-php-ext-install pdo_mysql mbstring zip exif pcntl bcmath opcache

Add this before "composer install" in the pipeline respectively in the Script - Section.

Like Roan Brouwer likes this

As the problem descriptions indicates, you are missing some php extensions.

So you would need to add sudo apt-get install php7.x-extensionname, for each missing extension.

 

I haven't used pipelines, but that seems to be the issue.

Thank you

We'll give this a go.

We tried adding the line:

apt-get install php7.1-gd

But we just get an error:

E: Unable to locate package php7.1-gd
E: Couldn't find any package by regex 'php7.1-gd'

Other posts (not necessarily pipelines posts) mention modifying the php.ini file to enable gd but I don't know where this is in Pipelines.

Full pipelines config being:

# This is a sample build configuration for PHP.
# Check our guides at https://confluence.atlassian.com/x/e8YWN for more examples.
# Only use spaces to indent your .yml configuration.
# -----
# You can specify a custom docker image from Docker Hub as your build environment.

options:
max-time: 7

image
: php:7.1.14

pipelines:
default:
- step:
caches:
- composer
script:
- apt-get update && apt-get install -y unzip
- apt-get install php7.1-gd
- curl -sS https://getcomposer.org/installer | php -- --install-dir=/usr/local/bin --filename=composer
- composer install
# - vendor/bin/phpunit

Like Pham Xuan Thinh likes this

It's a Laravel application

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

Git push size limits are coming to Bitbucket Cloud starting April 4th, 2022

Beginning on April 4th, we will be implementing push limits. This means that your push cannot be completed if it is over 3.5 GB. If you do attempt to complete a push that is over 3.5 GB, it will fail...

2,110 views 2 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you