Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,377
Community Members
 
Community Events
176
Community Groups

Pipelines "scp-deploy" puts everything in "build" dir on the remote server

We're trying to deploy a simple PHP project with no build process, all we need to do in the pipeline is `scp` copy the files up to a remote server.

Here's our pipeline config:

image: php:5.6.30

pipelines:
branches:
master:
- step:
script:
- pipe: atlassian/scp-deploy:0.3.3
variables:
USER: '<username>'
SERVER: '<ip addr>'
REMOTE_PATH: '/var/www/api/v1/'
LOCAL_PATH: $BITBUCKET_CLONE_DIR

We want it to put the files from the repo into /var/www/api/v1 on the remote machine, but instead it creates a `build` dir that looks like it has 777 permissions, and puts them in there. (/var/www/api/v1/build/<files>)

Where does this build dir come from? Can we disable that? Or do we have the wrong `LOCAL_PATH` value?

 

1 answer

1 accepted

1 vote
Answer accepted

Hi Duncan,

Thank you for your question.

In your case use:


LOCAL_PATH: '${BITBUCKET_CLONE_DIR}/*'

To deploy only files from your directory to the remote you can provide '/local/path/build/*' with trailing asterisk symbol (*) as a LOCAL_PATH variable.

Thanks! That looks like it copies the correct files, but they all have 777 permissions on the remote machine. Is there something else I need to do to specify the target permissions?

Like # people like this

Pipe "SCP deploy" preserves modification times, access times, and modes from the original file. Try to check permissions on your local at first.

But additionally, you can add to your config "SSH run" pipe with a command that modifies targets permissions on the remote:

- pipe: atlassian/ssh-run:0.1.3
variables:
SSH_USER: $USER
SERVER: $SERVER
COMMAND: 'chmod 755 <your_target_file>'

More information about pipe "SSH run" you can find in the Bitbucket Pipelines SSH run repository.

Atlassian created pipes are kept in the Bitbucket Pipelines pipes project.

Like # people like this

It would be good to have this on the pipeline information screen (on the screen when adding a new pipeline)

Like mkarthauser likes this

The problem is the trailing asterisk symbol (*) in the LOCAL_PATH variable leads to the fact that hidden files will not be copied (any files starting with "." - .htaccess, .env, etc). It is a general Linux behavior, but it would be nice to have some way to copy the hidden files and don't have a "build" directory on the server.

I found a solution: just use atlassian/rsync-deploy  and a slash at the end of LOCAL_PATH. Then hidden files will be copied and "build" dir will not be created.

script:
- pipe: atlassian/rsync-deploy:0.4.4
variables:
USER: $USER
SERVER: $SERVER
REMOTE_PATH: '~/projects/${BITBUCKET_REPO_SLUG}/'
LOCAL_PATH: '${BITBUCKET_CLONE_DIR}/'
Like schind likes this

hi, 

is there any way I can use more than two remote path like I want to move two folder build and config from my bitbucket to two different location on my server.

Is there any way we can do this without rewriting the steps.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events