Pipelines build error / Probably an error with pipelines

Hey I use pipelines to build my application and it worked great. Today, however, this problem appeared:

[RuntimeException]                                                                                                                        /opt/atlassian/pipelines/agent/build/node_modules/debug/debug.js:126                                                                        debug.color = selectColor(namespae);                                                                                                                                ^                                                                                                             ReferenceError: namespae is not defined                                                                                                       at createDebug (/opt/atlassian/pipelines/agent/build/node_modules/debug/debug.js:126:29)                                                  at Object.<anonymous> (/opt/atlassian/pipelines/agent/build/node_modules/eslint/lib/code-path-analysis/debug-helpers.js:12:29)            at Module._compile (module.js:413:34)                                                                                                     at Object.Module._extensions..js (module.js:422:10)                                                                                       at Module.load (module.js:357:32)                                                                                                         at Function.Module._load (module.js:314:12)                                                                                               at Module.require (module.js:367:17)                                                                                                      at require (internal/module.js:16:19)                                                                                                     at Object.<anonymous> (/opt/atlassian/pipelines/agent/build/node_modules/eslint/lib/code-path-analysis/code-path-segment.js:12:13)        at Module._compile (module.js:413:34)

Zaznaczenie_003.jpg

Judging by the 

/opt/atlassian/pipelines/agent/

This is not a problem with my application but error on the side of the pipelines.

2 answers

1 accepted

1 vote
Accepted answer
Joshua Tjhin Atlassian Team Dec 14, 2016

Piotr, looks like one of your dependencies or transitive dependencies debug.js has a typo namespae. 

I found the issue https://github.com/visionmedia/debug/issues/358 and it should have been fixed.

The reason why it suddenly stopped working is that this time, on npm install, it pulled a newer version of debug.js with the error. You could try using npm shrinkwrap or yarn to fix your dependency versions

1 vote

Looks like you misspelled "namespace"

 

debug.color = selectColor(namespae);

Me or service of Atlassian? I do not even use this package. Look at the path:

/opt/atlassian/pipelines/agent/

It is not related to my project. Unless I am doing something wrong. Yesterday, however, everything worked and did not make any changes that affect building my application.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 06, 2018 in Bitbucket

Upgrade Best Practices

Hello! My name is Mark Askew and I am a Premier Support Engineer for products Bitbucket Server/Data Center, Fisheye & Crucible. Today, I want to bring the discussion that Jennifer, Matt, and ...

194 views 3 6
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you