Pipeline FTP Not Working

Hi,

I am trying to setup a Pipeline that will push any commited changes through FTP to my website.

I have done this before and it has worked without an issue however after trying to do this for another private repository with the same host it is not working.

The strange thing is that it's not even spitting out an error - instead the Pipeline just keeps working indefinately (4m+) and I eventually shut it off to save my minutes.

Here is the code that is not working (from the following tutorial: https://www.youtube.com/watch?v=8HZhHtZebdw&t=80s)

---

# This is a sample build configuration for PHP.
# Check our guides at https://confluence.atlassian.com/x/e8YWN for more examples.
# Only use spaces to indent your .yml configuration.
# -----
# You can specify a custom docker image from Docker Hub as your build environment.
image: samueldebruyn/debian-git

pipelines:
  default:
    - step:
        script:
          - apt-get update
          - apt-get -qq install git-ftp
          - git-ftp init --user $FTP_USERNAME --passwd $FTP_PASSWORD headstudios.com.au

Below is the screenshot of the Pipeline that I stopped after it was running for over 4 minutes:

http://prntscr.com/hsu9r5

Now the weird thing is that it doesn’t give an error or anything. I’ve even tried to do the git-ftp init with a wrong password and it didn’t spit out an error after. It just stops and keeps going.

However here is where it gets interesting - when I change ‘headstudios.com.au’ to ‘wetcheck.com.au’ in the .yml file it DOES spit out an error as so:

http://prntscr.com/hsubi8

Which is very confusing to me - because it says that it can’t access the remote 'ftp://webapp%40headstudios.com.au:***@wetcheck.com.au' - but where is ‘ftp://webapp%40headstudios.com.au:***' coming from?

 

Any feedback would be much appreciated.

 

1 answer

I should note I can't connect to the FTP for my site either - it keeps timing out in Filezilla too - which is good because I can just contact GoDaddy and discuss. Hopefully it's just a server related timeout issue.

Suggest an answer

Log in or Join to answer
Community showcase
Piotr Plewa
Published Dec 27, 2017 in Bitbucket

Recipe: Deploying AWS Lambda functions with Bitbucket Pipelines

Bitbucket Pipelines helps me manage and automate a number of serverless deployments to AWS Lambda and this is how I do it. I'm building Node.js Lambda functions using node-lambda&nbsp...

654 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot