Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Permission denied on atlassian/aws-lambda-deploy

Lucas October 17, 2019

I use atlassian/aws-lambda-deploy as pipe to deploy code to AWS Lambda, I have 2 environments , and they are dev and production. However, after deploying to dev successfully, and going to production deployment, it fails at step update-lambda.sh whereas I believe the code deployed successfully to production, it just marks the status failed due to lacking permission to write artifacts files

Screenshot 2019-10-17 at 10.00.24 PM.png

2 answers

1 accepted

4 votes
Answer accepted
Lucas October 22, 2019

@Ana Retamal 

There is a work around solution that we need to run this command at the end of each lambda deployment step (except the last one) to clean the artifacts data

rm -rf /opt/atlassian/pipelines/agent/build/.bitbucket/pipelines/generated/pipeline/pipes/aws-lambda-deploy-env

 

Hopefully, the team will fix this problem soon by upgrading the image. 

dhenard
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
May 22, 2023

I had to delete the folder instead of just the file to get it to work.

rm -rf /opt/atlassian/pipelines/agent/build/.bitbucket/pipelines/generated/pipeline/pipes
Like Steffen Opel _Utoolity_ likes this
0 votes
Lucas October 17, 2019

I fixed it. Thanks

Ana Retamal
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
October 22, 2019

Hi Lucas, glad you fixed it!

It would be great if you could share your solution with the rest of the Community, in case anyone encounters something similar. 

Have a good day :) 

Ana

Like Steffen Opel _Utoolity_ likes this

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events