Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Open repo via URL and Private repo settings not correct in Web interface

Problem: 

I created a list of URL's to open my repos so auditing my permissions will be a bit easier.

Here's an example: https://bitbucket.org/<workspace>/<myrepo>/src/master/

When I open a repo with the above URL from a document, Chrome opens to the repo.

I then go to the "Repository Settings".

It shows the Access Level "This is a private repository" as unchecked which is not correct.

If I force a refresh of the page the Access Level "This is a private repository" now has a check in the box. 

My concern is my repos may accidentally become public.  

Is anyone else seeing this issue opening repo's this way?

2 answers

0 votes

Hi @sjamisorc ,

Another way to check whether the repo is private or public is by checking its avatar when you open https://bitbucket.org/<workspace>/<myrepo>/src/master/. If the avatar has a small icon of a lock on its top right corner, then the repo is private.

You can also check the same in https://bitbucket.org/<workspace>/ where all repos of the workspace are listed along with their respective avatar.

In order to find the culprit here, could you please let me know:

  • Can you see a lock in this repo's avatar?
  • Is the option "This is a private repository" now enabled or disabled for this repo?
  • Can you check the Project settings of the project that contains this repo, and let me know if it's a Private project or not? (every workspace repo belongs to a certain workspace project)

Kind regards,
Theodora

Thanks for the reply

The repositories avatars do have the lock symbol

The workspace and all projects are marked as private in the settings

 

Here's a screenshot of what I'm still seeing

repo-private.png

Hi @sjamisorc ,

Thank you for your reply and info.

I can see your details in our system and which workspaces you have access to. I was able to locate the project that is displayed in your screenshot, and I can confirm that all repos belonging to this project are private (another way to check this yourself is if you open the URL of the repo in a Private/Incognito window of your browser, where you are not logged in https://bitbucket.org/, you should then see an error page with the message "We can't let you see this page").

The checkbox This is a private repository being unchecked is indeed strange. I would like to ask a few things, so we can narrow down the cause of this issue:

  1. Could you please let me know what browser you are using + version of this browser?
  2. Do you see the same issue (this checkbox unchecked) if you log in to https://bitbucket.org/ from an Incognito/Private window of this browser, with all browser extensions disabled?
  3. Do you see the same issue if you try viewing this page from a different browser?
  4. Could you ask another admin of this repo if they see the same issue from their computer/browser?

I would like us to narrow down whether this is a browser specific issue, or if perhaps some browser extension may be causing this.

Kind regards,
Theodora

Like sjamisorc likes this

Thank you for looking into this.

My Browser and version are

Google Chrome is up to date Version 88.0.4324.150 (Official Build) (64-bit)

Yes the issue shows up in the incognito window with all extensions disabled and all browsers closed and new instances opened

Yes the issue shows up in Microsoft Edge Version 88.0.705.68 (Official build) (64-bit)

I use windows and had another admin with a Mac duplicate the issue.

This link generated the issue consistently. Once the source view is open I then click on the repo settings and the Private option is unchecked but the repo avatar has a padlock symbol. The master branch does exist and is the default branch

     https://bitbucket.org/<workspace>/<repo>/src/master 

 

This link does not generate the issue using the same workspace and repo

    https://bitbucket.org/<workspace>/<repo>

 

This variation of the url

    https://bitbucket.org/<workspace>/<repo>/admin

Causes the left menu to vanish.  Please see the attached image

bbviewissues.png

Hi @sjamisorc ,

Thank you very much for the info.

I am a bit confused about what you mentioned with the URLs.

You mention that the following link generates the issue:
(1) https://bitbucket.org/<workspace>/<repo>/src/master

But this link does not generate the issue:
(2) https://bitbucket.org/<workspace>/<repo>

 

- If I understand correctly, the issue occurs when you navigate to Repository settings while URL (1) is open, but if you go to Repository settings when URL (2) is open, the checkbox for private is checked?


URL (2) should redirect to the default landing page of the repo. If the default landing page is Source and the repo's main branch is master, then it should redirect to URL (1).

 

- What is the default landing page for this repo? (You can find it in Repository settings > ADVANCED > Default landing page)


- Do you get redirected to this page when you use URL (2) ? Does URL (2) change when you enter it in the address bar of the browser?

 

- It is also a bit unclear to me what you mean with variation of the URL https://bitbucket.org/<workspace>/<repo>/admin

Selecting Repository settings should always open https://bitbucket.org/<workspace>/<repo>/admin
Do you see a different behavior/URL, depending on which page you are selecting Repository settings from?

Kind regards,
Theodora

If you are with Atlassian support we may need to have a zoom meeting so I can show you exactly what I am seeing.  If that is not possible then I will produce a document of screenshots or share a video showing exactly what each URL produces.  Please let me know

 

If I use this URL: https://bitbucket.org/<workspace>/<repo>

it redirects to this URL: https://bitbucket.org/<workspace>/<repo>/src/master

Then I open the settings and the Private option is checked.  Everything works as expected 

 

If I bypass the redirect and use this URL: https://bitbucket.org/<workspace>/<repo>/src/master

Then go to settings.  The private option is unchecked.

I can use the same repository for both tests above with the results I've listed.  

The default landing page is listed as Source in Advanced setting with the default branch as Master.

There are data and rendering issues when using URLs that directly connect to /src/master or to /admin of a repo.

@Theodora Boudale 

I created a video of what I am seeing with this issue.  I would rather not make it available to the world.  Is there a way I can message the URL to you directly?

Hi @sjamisorc ,

Thank you for the clarification, I believe I understand what you're describing.

I am still unable to reproduce this behavior though. Just to clarify one more thing, this behavior is not specific to a certain repo, but to all repos you open this way?

My suggestion would be that I open a support ticket for you for this issue. The support ticket will be visible only to you and Atlassian staff, so you can upload in the ticket the video you have recorded and also request for a video meeting, if necessary. If needed, the support engineer working your ticket can also access any repos in an attempt to reproduce and troubleshoot this issue, and for that an open support ticket is necessary. I'm afraid we don't have a way for you to message me directly, and I am also limited in what I can access/view in order to be able to better help you.

Please feel free to let me know if you would like me to proceed with opening a support ticket for you.

Kind regards,
Theodora

@Theodora Boudale I checked the first 20 of my 100+ repos and it shows up on all of them so far.   I also have a co-admin that can reproduce this issue that uses a different operating system and browser.

This is a strange one and has the potential for a user to change the privacy setting unintentionally.

Please create a support ticket and I appreciate your help and follow up.

Thank you

-Shawn J>

Hi Shawn,

Thank you for the info.

I went ahead and opened a support ticket for you for this issue, you should have received an email with a link to the ticket.

I filled in the ticket description the description of your community question, however I have left an internal note in the ticket will all the additional info and explanation you have provided me and also a link to this community question. Please feel free to upload your video in the ticket.

If you have any questions or need anything further, please feel free to let me know.

Kind regards,
Theodora

My workspace is set as private as well

If I select the checkbox to make the repo private again the Save Changes button does NOT activate.  

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
TAGS
Community showcase
Published in Bitbucket

New improvements to user management in Bitbucket Cloud 👥

Hey Community! We’re willing to wager that quite a few of you not only use Bitbucket, but administer it too. Our team is excited to share that we’ll be releasing improvements throughout this month of...

3,884 views 10 16
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you