Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,995
Community Members
 
Community Events
176
Community Groups

Only access to one of my repos

I connect to bitBucket with SSH-key, and the puplic key is added under personal settings (not under repo settings) so I would expect that the key should work for all repos. Anyway, I can only clone one of my repositories. I also just created a new fresh repository from WEB login, but same problem when I try to clone that one:

Unauthorized
fatal: Could not read from remote repository.

1 answer

1 accepted

0 votes
Answer accepted
Syahrul Atlassian Team Mar 20, 2022

Hi @la55e

G'Day!

When the SSH public key is added under your personal settings it should follow your personal account permission when cloning repositories as long as you have the permission to access it.

Could you try to clone via the CLI with the following parameter:

GIT_TRACE_PACKET=1 GIT_TRACE=1 GIT_SSH_COMMAND="ssh -vvv" git clone <url>

The verbose logs should show if it's correctly using your SSH key generated or not. Look for "Will attempt key" keywords in the logs which should show that git is trying the list of SSH keys in your local machine that has access to clone the repositories.

If it's not using the SSH keys correctly you can change this by creating an SSH config file by creating it under ~/.ssh/config

Host bitbucket
 HostName bitbucket.org
 IdentityFile <path to your sshkey>

I hope this helps.

Cheers,
Syahrul 

Thanks Syahrul,

I found a solution. In addition to the keys I had under "personal settings" I also had one key for the repository which I could access. When I removed this key, I could also access the other reopsitories. Do not know why, but now it works :-)

BR

Lasse

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events