Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,576
Community Members
 
Community Events
176
Community Groups

OAuth Error redirect uri did not match any configured URIs.. Bitbucket Slack integration

Edited

After following the steps outlined here:

 

https://confluence.atlassian.com/slack/use-slack-and-bitbucket-server-together-974387205.html

 

I was able to get a connection between the two applications, but when I was asked to confirm access to Slack from bitbucket I get the following error when clicking on the link:

 

OAuth Error: redirect_uri did not match any configured URIs.

Passed URI : http://XXXXXXXX.com/bitbucket/rest/slack/latest/oauth/redirect/TL7P64848

 

 

I created a self signed certificate and verified that when I open the bitbucket page I see the certificate. Using Apache & Openssl 

 

My question is, I'm I missing a configuration file that i need to edit in order to updated the "Passed URI"?

 

Do I need to configure any additional connector or proxy configs? 

 

4 answers

1 accepted

0 votes
Answer accepted

I Found a different add-on to use that works as intended.

This post can be closed

What add-on did you go with in the end?

I ran into this same issue when I forgot to set the URL for our Bitbucket instance when adding the app to our slack workspace. 

https://slack.com/apps/AK9SSVATB

Maybe I should update the bitbucket.properties with the following:

 

scheme="https"
proxyName="XXXXXX.com"
proxyPort="443"

 

 

Any suggestions?

The issue is the redirect as stated in the error message:

 

OAuth Error: redirect_uri did not match any configured URIs.

Passed URI : http://XXXXXXXX.com/bitbucket/rest/slack/latest/oauth/redirect/TL7P64848

https://caci-nsis.slack.com/oauth/authoriz

What I cant find is where to properly place this "redirect_uri" 

 

I've tried placing the redirect_uri within the credentials portion of the slack integration page on the bitbucket server, but it does not seem to be noticing it.

 

Also the redirect_uris I've tried are:

https://slack.com/oauth/authorize

the passed uri in the error message

the bitbucket server, which is what the Passed url in the error message redirects to.

 

Documentation I'm using:

 

https://api.slack.com/docs/oauth

 

it just does not specify where to place the redirect_uri.. or i just dont seem to find it

Is this a step that would be needed as well?

 

https://confluence.atlassian.com/bitbucketserver061/if-you-use-self-signed-certificates-968674621.html

 

Could it be a contributing factor? 

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events