Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
badges earned

Your Points Tracker
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Now unable to connect to push git repo to bitbucket - authentication problem Edited

So I've had this repo for a long time - set up my account with email and password years ago.

Couldn't connect to push to the repo today, so logged into the bitbucket website, or tried to - reset password link sent to my email, reset that and went to a bitbucket area on atlassian - but no repo!!

Eventually got in by using my email (gmail) to authenticate, and could see my repo there.

However, I can't push my local repo to bitbucket - tried using original password, revised password AND even my gmail password. But I get:

remote: Invalid username or password
fatal: Authentication failed for ''



2 answers

1 accepted

0 votes
Answer accepted

Hello @christinamcg ,

Welcome to the Community.

If you're logging into Bitbucket with your Google account (SAML), you can't use your Google credentials to pull and push repositories. You need to either switch to SSH or create an App password with repository read and write scopes which you'd use along with your Bitbucket username.

Hope this helps. Let me know if you have any questions.


Thanks for the welcome!


So it looks like maybe I was using https to push and pull, with my butbucket credentials (pre Atlassian account) - does that sound right?

I actually thought I was using SSH but it doesn't look like it. I'll make the switch to SSH now.

Many thanks!

Yes, it was using https - now switched to SSH and all working fine!


Many thanks!

Like Daniil Penkin likes this

Hi, while pushing your repo, did the shell (I'm assuming you were doing this from the terminal) prompt you for logins?

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Bitbucket

New improvements to user management in Bitbucket Cloud 👥

Hey Community! We’re willing to wager that quite a few of you not only use Bitbucket, but administer it too. Our team is excited to share that we’ll be releasing improvements throughout this month of...

265 views 2 10
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you